How fix denial of permission to erase or write on one share

my 4TB WD MyCloud is installed as a drive on a wireless network on my NetGear router. All works as it would except for inability to write to one of the shares on the MyCloud. The message says “The currently logged in Windows user does not have permission to write or delete from this location.”

I haven’t found the place in MyCloud or Windows 10 to grant access.

It’s in the Share configuration section of the Web GUI.

Thanks,

If you mean Access Control in the IP address of the router network, it now says “Allowed” for the entire WDMyCloud ipaddress as for all other devices.

In topic/237661/773457@community.wd.com, on 05/20/19

No, he is talking about the My Cloud Dashboard GUI. There is a Shares tab in the Desktop where one can set the user permissions per Share if a Share has been configured to Private.

https://support-en.wd.com/app/answers/detail/a_id/15104

Example My Cloud Dashbaord:

Here is the setting of the MyCloud dashboard. I’m Ken!

Try changing the User Access for the User on that one Share to No Access, wait a few seconds, then change it back to Full Access.

It should also be noted that Windows generally doesn’t like it when the user uses two or more user names to access the My Cloud. One may have to access the Windows Credentials Manager to remove any My Cloud entries, reboot the computer, then try access the Share(s) again.

If you’re Ken, then you should have Read/Write to “ken” and “ken2,” Read Only access to “gretchen”, and no access at all to “gretchen2”

Are you sure you’re mapping the share(s) using the “ken” credentials? Which share are you unable to write to? (Your initial post says you can not write to one of the shares, but the settings say you should be unable to write to two of the shares, gretchen and gretchen2.)

FIXED. THANK YOU AND ALL FOR THE HELP

Removing and restoring the access had no effect.

The Windows Credential Manager route seemed to fit the literal error message so tried it and it worked. The second user name was the only one appearing. Removed the entire reference to WD-MyCloud and all now function as intended.

Ken

In topic/237661/773487@community.wd.com, on 05/21/19