How do you delete all you Time Machine backups?

I have run out of space on my WDMy Cloud. I cannot for the life of me figure out how to delete all of the backup files without a reformat. I can’t see them in sequence via Time Machine but cannot find a way to delete them. Any help will be greatly appreciated.

You can access the MyCloud shares via Finder.

Then you should be able to find and delete the unwanted backups.

Timemachine will (should?) automatically recycle the allotted space on your WDMYCLOUD that has been assigned to Timemachine backups. In other words, it will (should) start back at the ‘front’ of the allotted space when it is filled. Check your settings in Timemachine. Works fine on my MacBook pro.

Paul.

I recently had a problem wherein TimeMachine repeatedly failed. Long story, part of it is that it complained it could not delete the sparsebundle file or folder. I searched and tried everything - there are many questions and answers about this online - but could not delete it. I tried using finder, of course; SUDO via terminal, etc. All attempts would look like they were working but ran forever without completion and not actually deleting the files.
On the MyCloud the backups were in a share folder with no permissions at all, so no obvious way to delete them.

I discovered a solution that may be helpful and save others a lot of time and aggravation.

  • Log in as admin, go to Users, click on Admin.
  • In the Share Access section find the share with the TimeMachine backups, change its permissions so Admin has read/write permission.
  • Go to Shares, click on the share with the TimeMachine backups, and click on the icon that looks like a paper folder with a minus sign, which means to delete the share. After you delete that share, all the backups in it are gone.
  • Create a new share to use for TimeMachine backups. It could have a different name.
  • Configure your MyCloud: Settings to use the new share for Mac TimeMachine backups.
  • On the Mac configure TimeMachine to use that new share.

Note WD says your admin user must have a password in order to enable TimeMachine restores, so now’s a good time to be sure that’s the case.

After I did all that, TimeMachine is working again. Phew!