How do I remove your awful drive icon which I did not ask for and restore the default osx icon?


#1

I installed the latest drivers for my two MyBooks and it replaced the default osx icons on my desktop with your own versions. This is irritating because:

a) at no point during the installation process was I asked if I wanted this change made; it just happened

and

b) they are terrible design

Who signed off the design of a drive icon with a static image of a dial with the needle in the red****? Such an astonishingly stupid idea. I might be savvy enough to realise out it’s a meaningless graphic, others won’t be. And it just looks rubbish. I wouldn’t care if I had the choice in having it, but here we are.

I want rid of it please.

Thanks.

(OSX 10.6.3)


Disk icon change
#2

Try this:

a. Keep the WD external drive plug in.

b. Double clicks on the “WD SmartWare” icon on the desktop.

c. Double clicks on the 'Extras" folder.

d. Run the “WD + TURBO installer” follow the instructions on the screen.

e. From the WD +TURBO Driver Installer, choose “Remove”, “YES”,

    Restart the computer before new change to take effect.

That will remove the static image of a dial with the needle in the red.  


#3

I have no such icon on my desktop. I don’t wish any ‘smartware’ either.

I bought standard MyBooks, not the mac branded ones if that matters. Besides, I installed these drivers to stop the known problem of the drives spinning down after inactivity (independant of the OS settings), which seems to have worked. Therefore I do not want to remove the driver unless there is another solution to that.

I want my original OSX drive icons back. That’s it.


#4

This is still a problem for me.


#5

You have I believe two options: remove the driver or change the icon within the driver kext.

I don’t recommend the former, as I have to believe there is a legitimate reason that WD went through the extra effort to develop a driver above and beyond the default OS X FireWire support.  However, the location of the driver is /System/Library/Extensions/WD1394HPDriver.kext (this will be useful for modifying the icon as well).

You can get the original FireWire icon from the resources in IOSCSIArchitectureModelFamily.kext in that same directory (do a “show package contents” on the kext).  Copy the icns file to another location that you have write access for.  Go to the resources folder for the WD kext and change the name of the FireWire icon to that of the Western Digital Passport one.  Delete the WD Passport icon and move the FireWire icon into place.  Reboot the system and your icon will be default to the old firewire one.

I did exactly this because I can’t stand the thought of that hideous icon even being associated with my drive.  The folks at WD should seriously consider contracting some icon design out to the talented folks that have made some of the older passport icons… a realistic one for the passport studio would be awesome.


#6

Seriously awful design. Mine changed this morning and I am FURIOUS! If I wanted a different look to my drives, I would have asked for it to do so. Idiots. 


#7

Here an easier fix for anyone that wants to change it.

  1. Find an alternative image (preferably PNG) of the drive. Google “firewire icon PNG” and you should find something. 

  2. Copy that image onto the clipboard

  3. Click the drive you want to change the image of and “get info” on it.

  4. Once the image in the left corner is selected, click paste and voila! It should change immediately. 


#8

I’m still subscribed to this topic, although I got rid of these drives and just use them for backups now.

The ‘fix’ above is actually what I did in the meantime, but it’s not really a fix; it’s a workaround. It doesn’t change the fact that WD changed the default drive icon for the drives, ie, if you go back to ‘get info’ and delete the icon that you pasted over the ■■■■ WD one, the ■■■■ WD one re-appears. See another discussion here http://discussions.apple.com/thread.jspa?threadID=2382950&tstart=0

Day to day, I was at least happier with this fix applied and I could live with it. But I’m still annoyed WD made any kind of unauthorised changes to my system — no matter how small and which despite my best attempts I could never find a way to undo. More so that WD did not respond in any way to this.


#9

On application WD +TURBO Installer --> Ctrl-Click --> Show Package Contents

Contents --> Resources --> WD1394HPDriver.kext --> Ctrl-Click --> Show Package Contents

Contents --> Resources 

You willl have two .Icns files.  Open twith Preview and Edit Paste the Icons with those of your choice.

Also you should do the same for WDUSBHPDriver.kext

Then start the installer to ‘set’ the drivers and icons


#10

I have the same problem.

Its annoying. Why would they do that? At the least there should be an option.

It didnt just change the one of my harddrive icons it changed all of them to that same lame icon.

Have you actually tried to do that copy and paste open?

Following your instructions to find the icon was good but you cant copy and paste in those files?  You can’t actually do it, it won’t let you. How can you edit an icon file that has 4 different sub files in it. Preview does not work.


#11

I can’t actually re-create the problem anymore as I don’t use those drives anymore, but I assure you the workaround I posted the link to a couple of posts up from the apple support forums did work at the time. Although it was only a workaround, not a fix.