How do I remove the USERS folder?

Ok, got the WD TV hub last weekend and so far I really like it… with exception of 2 things… HD audio :frowning:

but here is something thats not really a big deal, just really annoying me. I setup a homegroup, deleted it, created a new one numerous times now. When i start with a brand new homegroup and do not do anything, join with the WDTV there is a folder called USERS on there thats shared. I dont want this to show up. I only want 1-2 folders shared that I choose.

So, go back to the computer, find the c:/users folder and its not like most folders, I cant just right click and choose NOBODY… i have to go into advanced sharing and uncheck share this folder… so I do that, apply it and restart my computer…

go back to the WDTV and voila… users folder is gone… BUT… after about 5-10 seconds its pops back up and is there again!!!

how do i get rid of this users folder and stop sharing it to my WDTV for good? I have also tried choosing to not share public folders in the network settings… im lost as to what to do.

If you’re actually talking about HOMEGROUPS, you can stop there.

WDTVs do not support ANYTHING having to do with Homegroups.

sorry, workgroup or whatever its called.

But that’s confusing.   You can neither CREATE nor DELETE a WORKGROUP.

Your PC is ALWAYS a member of a workgroup as long as you have Windows Networking activated.

So please, explain EVERY STEP you’re doing so we can see what’s going on.

well in control panel, networking I chose to leave the workgroup… then joined again… but i never got to choose a new name for it… it always chose my last name by default as the name?? but did give me this long weird temporary password to print out and save…

but didnt need that password to join the wdtv, just signed in as administrator and my admin password.

am i doing something completely wrong?

You are describing the HOMEGROUP connectivity.

You need to set up your computer on the WORKGROUP.

Open Control Panel.

Click “Choose HomeGroup and Sharing Options.”

click “Change Advanced Sharing Options”

On that screen,  select:



TURN OFF PASSWORD PROTECTED SHARING (unless you want that option)


Make sure the HUB’s WORKGROUP name is the same as your PC’s WORKGROUP name.

k, thanks… ill check this out tonight.

Okay, looks like you were right. I was setup using Homegroup and not Workgroup. So i left the homegroup and created a workgroup called “workgroup”… then in the WDTV i joined the workgroup…

BUT Im still seeing that dang USERS folder!!!  even after I chose to unshare it, it comes back up!

im wondering, is it because im signing intot he WDTV under “administrator” ??? should i create a new user specifically for the WDTV??

You probably want to turn OFF “Public Folder Sharing” 

already did that.

any other thoughts? this is bugging me

i did create a new user and signed into the workgroup on my wdtv as “wdtv” and still same thing…

The Users folder will always be shared because you have to log into the PC on the network for sharing to work thereby becoming a shared user. You can restrict other user’s access by changing their individual permissions to shared resources, but so long as a user is logged onto the PC the WD TV will see them as a user and show the Users folder.