How do I know if all my photos have gone over from icloud?

I apologise in advance. I really haven’t a clue what I’m doing but I’ve purchased a My Cloud 2TB so that I can get my photos from icloud onto it.

So, it seems that my photos have gone over automatically via the app on my iphone but as they appear to be in a random order, how do I tell? There seems to be no search facility and there also appears to be nowhere to say how many photos of gb of data is on the My Cloud drive. Unless I am looking in the wrong place of course, which is more than likely!!

I also, didn’t take off my auto-lock timer, which I now know is very daft. But then I am good at being daft!

I hope someone can help. Many thanks in advance.

Use Google Photos. Best there is

Thank you whsbuss for your reply

I do use google photos, It is good but I cannot use it for such things as photobox to make an album. To get my photos onto photobox, I first have to download them from google photos or icloud to my laptop, so that I can then upload them to photobox.

I haven’t the space to do this. Hence the purchase of a Mycloud device.

Ok. I’ve got a bit further, I think. But this seems to have thrown up more issues. I’ll try and explain, the best I can. I really hope that someone can point out where I’m going wrong.

I am still trying to upload my photo library from icloud. Firstly, there seems to be no way of telling how many photos have been uploaded. Given that, I tested for a certain photo to find and I can’t find it on WD but it’s still there on icloud. So I am guessing that about 2/3rds of my photos have been uploaded. I am going to call this sampleA for later reference. I’ve put everything into folders and set my auto-timer to never too.

I have tried uploading from a Macbook, Ipad and Iphone. The later 2 via the app. I then went on to try and upload just an album via the app. I’ll call this album AlbumA. Only 18 photos of 78 were uploaded. I tried again but then the app uploaded SampleA all over again, even though I selected just AlbumA. As I didn’t want SampleA again, I decided to delete them. That was when I got this error message “* P3030017.JPG - Internal server error. Retry your last operation. If the error persists, contact WD Support for assistance. (200006)”. Again and again, I get this message and I cannot delete this 2nd SampleA.

I am finding this extremely frustrating. Apologies. Would still hope that someone can help me though.

Ok. I was hoping some kind soul would be able to help me.

If someone could point me to a place where I can get help with this, I would be very appreciative.

Thank you

I’m still keeping my fingers crossed that someone can help. I have emailed WD but I’ve not even had so much as an acknowledgment.