How do I improve my upload speed

I am a very non technical user, but I’m thinking that my speed from my extra internal 2TB drive to my brand new 6TB My Cloud is pretty slow.  It takes about 2 1/2 minutes to transfer 1 GB of data.  Isn’t that a little slow, or maybe even way slow?  My computer is not doing anything else, I am using MS Explorer to transfer on a Windows 7 computer 64bit with 16GB ram.  I am connected from my computer to my router by Cat 5 ethernet cable, and of course to the WD My Cloud the same.  I will be very grateful if someone can tell me what I can do to speed this up, if anything, in very simple and non-technical language?

Thank you in advance.

1 Like

My first question is going to be a bit technical, I’m afraid…

What sort of Ethernet ports do your computer and router have? Are they gigabit Ethernet, or 10/100Mbit?

For gigabit Ethernet, cat5e or cat6 is usually recommended.

1 Like

Thanks for your response.  I just looked at my specs and it says:

LAN: 1000-Base-T
Interface: PCI Express x1
Technology: Realtek RTL8111E gigabit ethernet controller
Data transfer speeds: up to 10/100/1000 Mb/s
Transmission standards: 1000-Base-T Ethernet

My router is a Linksys EA 2700 which says in the promotional sales info that it has 4 gigabit ethernet ports.  

From that it sounds like I’ve got the right ports, now, does the cable that comes with the WD My Cloud work for that and how do I know if I have the right kind of cable from the computer to the router?

That all sounds good. Now you need to check that a gigabit connection has been established between router and MyCloud: read p11 of the user manual. You should see one steady green light and one flashing (activity) light on the drive’s Ethernet socket.

As for the cable, the one supplied is cat5e; the spec is printed on the cable, and it will be on any half-decent Ethernet cable. A short (1-2m) cat5 probably won’t be a problem.

You might want to read this:

1 Like

Thanks again.  I’m going to go read page 11 of the manual and that document on the link.  Yes, my cable between the computer and router is marked as Cat 5e and the lights on the back of the device are one solid green and one flashing green and the ones on the back of the computer by the ethernet port are one solid green and one flashing orange.  I’ll go read those documents and see if that helps.

I’ll post the results.

I read the documents you recommended and determined that I’m connected correctly and the lights on the device indicate that I’m at Gigabit speeds.  The one you linked to mostly tries to explain why it is so slow, but didn’t offer any fixes that helped.   I decided to conduct a test and uploaded a 4GB file folder full of photographs to Dropbox and it took 49 seconds.  I uploaded that same folder to WD My Cloud and it took 9 minutes and 52 seconds.  I don’t get why it can go through my ISP and to Dropbox in 1/12th of the time that it goes to my local device???

I do appreciate you taking the time and effort to respond as you did and the information you helped me with and you doing it in as low tech a way as you could.  You and those like you are what makes these forums so valuable!

Hi, what would happen if you transfer a single file of 4GB? Something like a movie or a Zip file with your photos.

I decided to conduct a test and uploaded a 4GB file folder full of photographs to Dropbox and it took 49 seconds

Okay, let’s take a look at that test.

4GB is 4e9 bytes. Assuming a 10b8b encoding (where the 8 bits of the byte are represented by 10 bits for error correction purposes), that gives us 4e10 bits. So we can calculate the data transfer rate you are achieving to Dropbox:

rate = 4e10/49 = 816Mb/s upload rate.

Are you using a gigabit internet link? Because I’m lucky if my ISP gives me 800kb/s uplink rate. Admittedly, that’s a slow, cheap connection.

Thus, I suspect that Dropbox is doing something ‘clever’; had you already transferred these files to Dropbox?

Now let’s look at the tranfer rate to your MyCloud.

Again, we start with 4e9bytes/s, or 4e10bits/s, in 9’52". That gives us 68Mbp/s, or 6.8MB/s. Not brilliant, but, if you’re transferring lots of images, you won’t get the sustained data transfer rate, as there will be a lot of overhead with directory stuff, going to get the next file, etc.

As has been suggested, try transferring a single, multi-gigabyte file (e.g. a movie file), and see how long that takes.

The thread I linked to discusses the practical limitations of data transfer, over a gigabit network; it was intended to serve as a ‘reality check’ for those expecting to get 125MB/s over a gigabit link, using the naive approach that 1000/8 = 125. Ralphael also reported transfer speeds he’s achieving (62MB/s write speed, and 30MB/s copy speed for photos):

So it looks like, compared with his experience, you aren’t achieving the speeds he is.

The other issue with the MyCloud is the image thumbnail and indexing processes; as soon as you transfer media files to the device, the processor will go off and start working on generating indexing and thumbnails for the new files, which slows the response of the entire thing. If you don’t need thumbnail images (they’re for remote access apps), you can turn these processes off, by logging into the MyCloud’s Linux system using SSH. But I fear that might be rather technical.

We users have regularly complained that there ought to be a control on the Dashboard to disable these processes, rather than having to use Linux admin skills. Sadly, our requests fall on deaf ears.

1 Like

SOLVED!!!  Thanks to tech support at My Cloud. 

Here is the problem and why it was so slow.  I know that many of you will shake your head and say what an ■■■■■ this guy is.  So I’m willing to admit that I am probably an ■■■■■, but my guess is that there are others doing the same thing that I did and so I post this and take the abuse to help the others that may be having the same problem and may be helped by the same solution.  cpt_paranoia and the others that tried to help never asked the right question or gave the right solution because it would never occur to them that I would do it the way I was doing it, and I never gave them the right information because it never occurred to me that there was another way to do it or I would have tried it and never had the problem.

The way I was doing the transfer was by opening the WD My Cloud application on my desktop, then opening the “Share” (which I think is a stupid name for a directory or folder) and then dragging and dropping the file from Windows Explorer into that directory.  According to the WD support guys I was sending my files through the Internet and then back into my device. 

By opening Windows Explorer and going under Network and selecting WDMYCLOUD and then the folder or “Share” and then opening another Windows Explorer window and opening the source directory on my hard drive and then just dragging and dropping from one Windows Explorer window to the other my speed increased dramatically because it is all done locally.  I uploaded that 4GB folder that I referred to in an earlier post in about a minute, though I didn’t time it exactly like I had before.  Right now I’m transferring a folder full of very smal files, just over 96,000 files making up 25 GB, and admittedly that is going much slower, because it does take a lot longer to transfer small files than it does large ones, but still going much much faster than it was by the other method.  I probably should have zipped the file and transferred it that way, but I don’t want to stop it mid transfer. 

Kudos to Tech Support for putting me on the right track, and I still do appreciate those others that tried to help before.

1 Like

I did wonder what tool you were using, but your OP said:

“I am using MS Explorer to transfer on a Windows 7 computer 64bit with 16GB ram”

And you’re right; I never would have guessed you would drag from the desktop app to File Explorer…

I’m not convinced that doing this would go via the internet, though; the WD App seems smart enough to know when you’re local to your network.

It’s another example of the problem of WD pushing the desktop app unnecessarily/prematurely. Only use the desktop or mobile apps when you are accessing remotely.

For local access, always map your drive into your OS’ file system, so it can be accessed just like any other disk. See p23 of the manual.

1 Like

Thanks.  I’ll check page 23 about that mapping stuff.  Remember the part about non hi-tech?