How do I find the "Smartware" version on my Passport Ultra 3TB?

I bought the WD drive last week because it was supposed to allow me to choose which file types to back up. I see no such option on the one that I bought; instead I can only slog through a very rough outline of the various files and folders on Drive C: and check the ones I want - time consuming and imprecise.
So: how can I find the “Smartware” version on the WD drive - or find out if there is any at all?

The version that came with your unit depends on the production date. You can check the app’s version in the Settings tab.

You can update to the latest version from WD’s site.

Thank you for responding. How do I access the Settings tab? If I R click on the WD drive icon on the computer, it causes a crash. Tried this several times, both through the Control Panel > “Devices and Printers” path and also via Computer…
The only shortcuts on the desktop (created at installation) are “WD Backup” and “WD Drive Utilities.” Neither has any Settings tab. (In fact the WD Drive Utilities just says “attach a supported device” even though the WD drive is attached and doing a backup right now.)

“WD Backup” as opposed to “WD SmartWare” means you have a new generation unit with a newer (WD Backup) application. Open the app from your list of programs instead of using the Device Manager. As a regular application, you can open and access it even with your WD Passport disconnected.

Doesn’t work. I can get to WD Smartware and Quick view, but when I click on it, it just disappears and nothing happens.
Start > All programs > Western Digital > WD Smartware > WD Quick View [icon] = no response.
There is a Quick View icon in the tray but that doesn’t work either. Click it, it only provides “About” which is Version 2.4.10. But no functionality.
I did manage to access Settings via “WD Backup” in the tray (after a few false tries) but when the device is disconnected it’s all grayed out so I can’t change anything. When the device is connected it’s like the sorcerer’s apprentice - starts blinking away and attempts to access controls are leading to Windows crashes.
(No such problems with my older Elements model.)

The WD Quick View opens in the System Tray (Lower-right corner, where the small icons near the date are grouped).

See if SmartWare is listed under your programs in the Control Panel. It will show as WD SmartWare, select it and try a repair.

If that will not work then download and install the SmartWare from here, if you need to.
http://www.mycloud.com/learn/?id=mycloud#mc_download

I thought I covered that. It does not open. When I Click it, it only provides “About” which is Version 2.4.10. But no functionality.

If I download and install new SmartWare, what happens to the files I have stored on the WD drive? In some cases they are the only copies I have, since I was using the device for storage to free up disc space.

Have you tried a reboot of your computer to see if that will solve your problem of opening up SmartWare?

Have you looked on your C drive for SmartWare? See image below.

If it is there do a right click on it and create a desktop shortcut, then see if it opens or just click on it and see if it opens.
Here is a link for the SmartWare User Manual. http://www.wdc.com/wdproducts/library/UM/ENG/4779-705057.pdf

You download and install SmartWare on your computer not your My Cloud.

thank you!
You have found at least part of the problem. No Smartware there. And I checked Programs & Features - instead of the Smartware app, it’s the installer!
The odd thing is: if the Smartware wasn’t installed, where did the icon come from (in the tray and under Start>All Programs>WD)?
Again, if I run the installer, will that have any effect on the files I have saved on the WD Passport?

OK, I got the Smartware installed and operating.
A couple of problems came up:
There are two folders on the WD drive that can’t be opened (“Not accessible - corrupted”).
But they also can’t be deleted: “Error 0x80070091. The directory is not empty.”
I don’t think it’s good to leave them there, but I don’t want to erase the entire disc either.
What’s the best procedure here?
Thanks again for all your help.

Forgot to mention: I also just ran “Drive Status Check” and it passed. Ran “Quick Drive Test” twice and got a “Failed” message both times - but nothing to indicate what the problem is.

You may want to look at this discussion and see if it helps.

Thanks for sending. Yes, I saw that thread also. A little different from my situation but definitely similar.
Anyhow I’m sending this defective unit back. Not worth wasting any more time on it.
The thing that I find strange is not being allowed to delete a folder because it’s not empty (stated reason on the error message). Well, yeah, I’m trying to delete the fold and all of its contents - a very common procedure.
The other strange thing is that I was allowed to rename the folder. But not open it, export it or delete it.