How do I do a manual update?

I followed the normal procedure to update the firmware but the system said it was an incomplete update and I need to do a manual update. I downloaded the latest update and followed the instructions.

I unzipped the 5 files to a USB drive.

I inserted the USB drive into the WD USB port.

Pressed HOME . According to the instructions the Firmware Upgrade icon should now display but it doesn’t.

Where do i go from here?

I’ve tried 3 different USB drives.

I’ve restarted but it tries to upgrade over the internet which is not available because of the incomplete upgrade.

See Tony’s post

also, use a small USB (2GB,4GB etc) fomatted FAT32

1 Like

Thanks Joey. Using that info I was able to do the update. Now just have to solve the no WiFi issue :cry:

Not sure if this will fix it Bob ?

Factory Reset ( Setup  > System  >  Device Reset  >  Reset All Settings Back to Factory Default )


salheart180 wrote:

You need to turn off Auto Detect Wi-Fi Direct setup in order to get the normal wireless settings back that you are looking for. 

I know because I was having the exact same problem.

Both were marked as a “Solution” so they must have worked for someone ?

Thanks Joey but I tried those fixes but neither worked for me.