How do I delete backed up files


#1

I used the Western Digital Backup programme to create a backup on my Western Digital Drive. I then uninstalled the backup programme but forgot to delete the backup on the NAs. How do I delete it?

Everytime I mount the drive in Finder and try to delete it it prepares all the files for deletion but it won’t actually remove them. I tried changing the permissions via Finder but this didn’t work either.


#2

I tried connecting via SMB too but the Finder wheel just keeps spinning when I try to delete. 


#3

Sounds like if you can’t delete files there is something amiss with the file ownership. If you look at the file owner information and it says “Unix User/nobody” you can delete these files with a third party ftp program logged in as the admin. BTW - The ftp program logged in as the admin gives you very powerful control over the files on the drive.


#4

I tried deleting the files using FTP programme Flow but it keeps telling me “chmod” failed and it won’lt let me change permissions. Is there something I need to do within the WD Live programme that comes installed on  the NAS?


#5

Do you have ssh enabled on the device? ssh into it using the terminal and login under root (default password welc0me) and run rm -rf then specify the folder containing all the files you wish to remove. You might have to first enable ssh if you have not already done so.  Log into the admin interface and click Advanced Mode. Then click the Advanced button and you should see “SSH Access” and check the box beside “Enable” and click Submit.