How can I increase private folder size? Default is 17.4GB

I’ve created a Private Folder on my My Book Live.

I can copy files to the Private Folder through windows.

Problem:

I cannot copy more than 17.4GB.

How can I increase the private folder to say 1TB??

I can’t believe nobody has come across this?

…not that I’ve ever heard…  because there are no such thing as Quotas on the MBL. 

Every share has equal access to all free space on the system.

There is no “default” folder size.

Why is this so complicated, when it should be so simple.

Ok. I’ve attached 2 screenshots. My private amd my public folders.

Public is work ok.

The private one is not working properly:

  1.   It only allows me to copy 17.4GB into it.

  2.   Windows says private capacity is 298GB, but blocks more than 17.4GB.

private.JPG

public.JPG

Thanks, but I’m still stuck any ideas?

I’ve only copied 10 GB into Private and I get this message when I try to add any more.

This WD My Book Live NAS is a joke.

problem.JPG

Sounds like your PC connected to it via WEBDAV instead of CIFS.   

Try this:

Open a CMD window and execute the command:

NET USE

Post the text output of that command.

problem2.JPG

That’s not text… that’s an image, and thus we have to wait for a moderator to approve it.

… but short of waiting for that, if any of the lines say “Web Client Network,” then what I said above is correct, and the problem is that your PC screwed up, not the WD.

Try turning off Window’s WebClient service.

“Enables Windows-based programs to create, access, and modify Internet-based files. If this service is stopped, these functions will not be available. If this service is disabled, any services that explicitly depend on it will fail to start.”

Thanks this fixed this.

Thank you very much.

So it was WebDAV.  Why can’t Western Digital fix this problem!  It’s annoying!  :angry:

Within the Windows networking configuration is it possible to tell it what to use first.  Like this . . .

Well, it appears to me that it’s not WD’s fault.   It’s Microsoft’s.  

The NAS can’t tell the client which protocol to use.   It’s only WD’s fault in that it will accept a WebDAV connection, but that’s a requirement for WD2go.

It would appear that MS tries to use CIFS, and under certain circumstances, the mount fails, so it tries WebDAV and then succeeds, so it sticks with WebDAV until you delete the connection.

@SVEN:   I would recommend you restore that option to the way it was, delete the shared drive connection, then reboot your computer and try it again.

Turning that service completely off may have an undesirable affect on other programs you use.

I’ve had the WebClient service turned off on my own computers for months without any adverse effect.  Everything works absolutely fine.  From someone that knows the woes of Microsoft networking inside-out, it’s safe to set the service to Manual (not Disabled) and start the WebClient service when something actually needs to use it.

It is WD’s fault because it should be possible to configure the Apache2 web server to refuse connections to WebDAV resources that originate within the local subnet.

Problem with Microsoft’s attitude when Windows XP was designed was that a lot of services that are not used are turned on by default.  Thinks like Microsoft’s Sharepoint product may use the WebClient.

It actually strengthens security a bit of the Windows OS to have WebClient turned off because other programs could connect to a remote server using the HTTP protocols and within a firewall CIFS and SMB communication is usually blocked from local subnet to wide-area network in both directions.  For defo inbound to the LAN.

Just set WebClient to manual start-up. If it’s needed by a specific program then it should turn on the service or you can turn it on yourself as opposed to a  default “always on”.

I’ve NEVER has my Windows installations connection to my MBL using WebDAV unless I deliberately configure my system to allows this to happen.

  it’s safe to set the service to Manual (not Disabled) and start the WebClient service

 when something actually needs to use it.

MANUAL is the default setting for that service… and when I first discussed this particular issue, mine was (and still is) set to Manual.  So that is certainly not a preventative measure.   

In fact, with that service set to MANUAL, I can still have Windows mount via WebDAV at will.   So DISABLE is the only option that will prevent that type of connection. 

 It is WD’s fault because it should be possible to configure the Apache2 web server

to refuse connections to WebDAV resources that originate within the local subnet.

That’s ignoratio elinchi…

It’s not WD’s fault to allow a protocol to be used.   It’s no different than if Windows decided for some reason to use NFS instead of CIFS when making a connection.     That wouldn’t be a bug if the WD allowed it…  It’s just doing what it’s asked to do.

If you have your Windows Client configuration set to use Microsoft Network before using WebDAV, it should do it, or at the very least warn the user that it’s using an alternative protocol.

Too, DISABLING WebDAV for local subnets would likely break WD2Go when you’re on your local network, or a the very least, require the client to use the WD2Go cloud gateway, which would be an unnecessary waste of bandwidth and expense.

No harm in disabling the service to see what happens. It can always be re-enabled.  :smiley:

If while it’s disabled everything works fine and dandy and when enabled this problem re-appears then it’ll either confirm or not if the WebClient service is for sure the problem and then it’s up to the person who owns their computer if they wish to have WebClient on or off.

All I know is at my end WebClient is shut-off and I’ve never experience any of my machines trying to connect to the MBL via. WebDAV disk and file sizes are correctly reported and data transfer is fast.

My advise…  Scuk-it-and-see for yourself and judge by the results you get.  :wink:

Hi!  

I have the same problerm: the total size and free space of my MyBookLive are reported as being the same as my local harddrive.

I have disabled WebClient, but now I just receive an error message every time I try to connect MBL:

“Windows cannot access \MyBookLive\Public”

 What else should I try to solve the problem?

Thanks,

Lejepra