How can I hidden "public" folder? (WDMyCloud 4Tb)

Hi guys.

like everyone, we´ve the public folder, and I think you can´t hide … at least from the UI interface.  Is it possible to hide the public folder using SSH?

I personally bother me much this folder :slight_smile:

I found here --> http://community.wd.com/t5/WD-My-Cloud-EX2/Hacks-to-make-Public-share-and-USB-shares-private/m-p/728740:

Making the Public share private (this change persist after reboots):
 
- SSH into the device and cd to /mnt/HD_a4/.systemfile/
Backup .smb.xml preserving file permissions, etc. to a file called .smb.xml.bak :
       cp -p .smb.xml .smb.xml.bak
- Open .smb.xml in vi
- Review the xml file before making any changes
- Changes we need to do will be under the first <item> section, with <name> Public
- Chage <public>yes</public> to <public>no</public>
- Next set user access permissions for <read_list></read_list> (granting read-only privs), <write_list></write_list> (granting read-write privs) and set <invalid_users>#nobody#</invalid_users> - the usernames that you use for read_list and write_list will need to be enclosed with # and multiple names will need commas to separate the usernames but there should be no spaces. Look at other shares you have created in the <item> sections below Public's and use them for guidance
- Set <web_public> and <media_flag> to have values like your other shares as well (for mine it is set to 0 but that may not be the case for you). The previous steps are the most important ones (setting <public> to no and setting permissions) and this step may or may not be required but I keep them the same as other shares anyway...since I don't plan on using the Public folder.
- Save the file changes and reboot EX2 - then go to dashboard and click Shares and then Public to verify your changes are now in effect
- Should you ever want to reverse this change, simply copy over the .smb.xml with the .smb.xml.bak (assuming you have not created or altered other shares - if you have then just reverse the edits by hand) and reboot

 Do you think this will work?

Hello,

The My Cloud drive does not have an option to hide the “public” folder. Some user have tried with non supported SSH commands . Lets see if any of those users will post on this thread.

Hi Please see my post for a quick workaround

http://community.wd.com/t5/WD-My-Cloud/Controlling-access-to-public-folder/m-p/698142

please give Kudos if this helps

1 Like

I have a new X4 and tried to perform your magic, but can’t locate the area to do this, is it from the dash board or one of the software programs that come with it.

john

Hi man.

It´s a partial solution but for me…

Your workaround chek ok:

Captura de pantalla 2015-01-27 a las 16.57.20.png

Now, only see “public” folder in my user, guest account show nothing

Captura de pantalla 2015-01-27 a las 16.57.58.png

But, I want to hide “public” folder… This solution only change “access” but I can see “public” in all my folders…

Hi Jonclaud

if you have the EX4 it is a different device to the WDMyCloud and has its own forum so this workaround probably is not valid for the EX4

Tel

Hi

Someone check the SSH script that I put in 2nd post?