Horizontal Lines

I have a DLNA server on my home network connected to a Samsung LED TV. All videos in my collection play perfectly and are very clear.

Today I purchased a WD TV Live Plus media player. It was fairly easy to set up, but I immediately noticed horizontal lines and stuttering with some of my videos. Many other videos play fine. The horizontal lines only appear with motion and are localized to the motion area.

All videos in my collection are encoded as .mkv/h.264/DTS and AC-3 Pass-thru. My network is wired gigabit. The TV connection is HDMI.

I tested several configurations in the media player, but cannot eliminate the distorted and/or stuttering video. I also tried two TVs and component video…both display the same behavior.

Could I have a bad player?

Blank Post?  Please see here: http://community.wdc.com/t5/Forum-Feedback/IE9-and-WDC-Forum-Compatibility/td-p/167170

I replaced the unit and still have the same problem. Earlier, WD suggested downgrading the firmware and playing a problematic video from a USB jump drive. No improvement, thus eliminating my network and streaming server.

The issue looks like interlacing lines and they only appear over areas of high motion (e.g. a person waving). Static frame content is clear. Animation especially shows the behavior while some non-animated videos just stutter. 

It seems reasonable that my files are compatible with the WD TV player. I wonder if they are too compressed, although they play fine and look awesome on my Samsung TV. The streaming data rate varies from 192 kbps - 448 kbps (animation the slowest bit rate). Most files in my collection are 720p.

I will test a few other formats, but hope to avoid transcoding my collection to another standard. All feedback is appreciated. 

What source is the content from?

Almost any 24fps DVD or BluRay you should have been able to rip with it’s native frame rate and not perform a 3:2 pulldown out to 30fps.

Played back at the native frame rate, there should be no artifacting.

You’d only get the interlacing lines if:

  • the original media was 3:2’d out to 30fps – in that case you could remove it by doing a reverse telecine when you make your rip, going back to a 24fps media file
  • it was added during your rip by creating a 30fps file from 24fps source material – in that case, matching the source frame rate when ripping would solve the problem
  • the WDTV is doing a 3:2 pulldown in order to play 24fps material on a 30fps display – in that case, matching the display rate to the source rate (if possible) would solve the problem

Unfortuantely, ALL NTSC DVDs are output at 30i, even if the original content is 24p.  

Only “Progressive Scan” DVD players will correct for this.

The WDs don’t do that, either.  They do NOT perform decombing.  You will ocassionally notice “Combing” artificats such as this:

IMG00123-20101009-1625.jpg

This is a screenshot of Star Trek: Voyager on my LG 1080p display from the Live Hub.   The Live / Live+ look the same, as does my LG Bluray player using the same disk.

TonyPh12345 wrote:

Unfortuantely, ALL NTSC DVDs are output at 30i, even if the original content is 24p. 

That’s why I was aking about the source. :wink:

All my TV DVD’s stay at 24fps when I run them through Handbrake and stick them into Matroska.

The .iso’s play at 30fps because that’s what the .vob headers are telling the file to be played at.

Yeah, If I’m HANDBRAKING my DVDs, I make sure to use “Framerate: Same as SOURCE” 

However, with DVD Content, that’s kind of a misnomer.   It won’t actually switch between 24p and 30i…  It will do 2:3 detelecine on the 30i parts, so I make sure I use the DECOMBING filter and ANYTHING that has the 3:2 flag set.

On that particular episode that I show above, here’s the results:

decomb: deinterlaced 957 | blended 866 | unfiltered 65964 | total 67787

Those 957 frames are much better now.  :)

TonyPh12345 wrote:

Unfortuantely, ALL NTSC DVDs are output at 30i, even if the original content is 24p.  

 

Only “Progressive Scan” DVD players will correct for this.

Not every Progressive Scan player will, will they?  I thought only the ones that actively support inverse telecine/3:2 detection were capable of ignoring the 3:2 flags within the MPEG stream.

But since 720p24 and 720p48 don’t exist, you’re still going to get some form of frame rate conversion when outputting to 720p.  It would only be if you were outputting as 1080p24 to a 1080p24 display that you’d be able to avoid the frame rate conversion artifacts.  Any other output will necessarily have the 3:2 pulldown.

On my TV, the 3:2 pulldown isn’t noticeable anyways… I only keep the .mkv files as 24fps because the 3:2 becomes objectionable if played on my PC and its monitor.

I’m ripping my DVD collection to VOB or ISO using AnyDVD. If the latter, I mount the ISO with Daemon Tools. I’m using HandBrake to render to MKV. I have no filters enabled, but do have the framerate set to “same as source”. My custom profile is simple:

  • Video Codec: H.264
  • Container: MKV File
  • Audio: AC3 passthru and DTS passthru.

The picture TonyPh12345 uploaded is similiar to what I see, only more extreme. My horizontal lines are localized to high motion areas within the frame.

Why doesn’t my Samsung TV have this problem? Should I move away from MKV/H.264? Also, where do I determine if the 3:2 flag is set?


***UPDATE***

I re-rendered a problem video file using the High Profile preset. This adds default detelecine and decomb filters. I changed the output to MKV and added DTS pass-through. The interlace lines are more subtle, so the filters seem to help. Will render again at 24 fps to see if that eliminates them.

I created a second MKV file using MakeMKV (MPEG-2 video codec). The first 10 minutes are flawless, but the interlacing eventually came back (also subtle).

Will keep testing until I find the right codec and filter settings. I’m still confused as to why my TV doesn’t have this issue?

Presumably your TV has a pretty good decombing filter in its processor.   

I have a LG GGW-H20I BluRay R/W player. I assume it is progressive scan?

Thank you RoofingGuy and TonyPh12345. You got the brain juices flowing :).  The “High Profile” settings (modified) in HandBrake did the trick. No rmore lines/stuttering.

Should I make this the default profile to convert my DVD collection…or is it “hit or miss” depending on the tile?

High Profile is a pretty good All-Around setting.   I made a couple of minor tweaks to it and saved it as my own default.

Ya, I just always use the “High Profile” and haven’t needed to muck about with things too much… my stuff is all pretty much just straight 24fps, so I don’t have to fiddle with anything.

The issue Tony had been having, if I remember correctly, was that a select few of his discs were almost entirely 24fps, but there were a few frames that were stored as 30fps (usually when the text was on the screen during the opening titles).  If I recall, Handbrake had seen there were a few 30fps frames, and wanted to make the entire file 30fps.  Tony can probably explain better. What was happening and how he overcame it.

If that kind of filtering is what “fixed” your files then it wouldn’t hurt to save the modified profile as your default.  If the filters aren’t needed then they won’t hurt by being enabled… as I say, they don’t get needed (or used) for strict 24fps stuff.

(and I hope you realize that when I type it, 24fps = 23.976 and 30fps = 29.97… I’m just too lazy to type the decimal places all the time :wink: )