Hoping someone can help me

I have been having this problem since august and have tried everything I can think of, well almost everything. Everything I am comfortable with doing myself.

So I moved, and when I set up my MBLduo 6t HDD the dashboard says the volume fails to mount.  the Icon on the bottom says bad and is red and says 0tb\0tb

The short test passes, the full or didnt last time I ran it back in sept.  I have it set up as Raid1 Maximum. and both drives read as good.

The drive appears on my pc (win8 64bit) under C:  but the MBL>storage says it is empty, previously this is where I kept my data

under my networks, under the Mybookliveduo>Public it says Windows cannot access it, check network connection. 

on my dashboard it says there is not internet connection, so I can’t even install the newest update, which I think is from April. 

It was working fine until I moved. Then this. I have tried different routers. I have contacted support, where I interacted with two people the first was helpful and tried to set up a phone meeting to go over things, which never happened. A week later, after I replied trying to set up another phone call, a second support person contacted me saying I had to send in my drive and they would fix it. I asked if it was just the unit or the data too. I have yet to hear a reply. That was november… 

So I am hoping someone can help here before, i figure out what else to do. I have seen a lot of  similar problems and solutions. But like I said i am not too familiar or comfortable with advanced stuff. So any help would be appreicated. Thank you


You should try a power cycle then try to map the drive using WD Discovery tool.

Mapping a drive letter on a WD Network hard drive using WD Discovery 

Thanks for the assistance

I tried  that twice on both the network attached storage and media server. 

Both times it says 


Is your MBL set to DHCP or static?  Check Dashboard, Settigns, Network.

If you cannot access Dashboard, then you probably have either static setup or your MBL is bricked.

I can connect to the dasboard manually. It’s set to DHCP. Its what tells me, there is no internet access, my volume fails to mount and 0gb/0tb. All that good information.

Interestingly, i can only sometimes connect via the disc. Most of the time i get a runtime exception error. Once in a while, out will go through but still no drive will be located. So there is real no big difference between disc or manually as far as i can tell.

I’d recommend you reinstall the firmware.  if you cannot, then do a debrick process.

you can trick the MBL into doing a firmware upgrade.

Do you have SSH access?  If you can trick the MBL to doing a firmware update


if not, then use the debrick guide on this forum

Thanks got the suggestions.

Will reinstalling the firmware lose my data?

I did try the ssh with putty command line. But the guide i find wasn’t got the duo.

Yeah i saw the debrick guide, but that included opening up the drive and connecting it via sata cable to my pc. So it’s a solution i would want to use as a last resort.

Thanks for your help. I’ll let you know how it goes