Recently bought my EX2 Ultra, with 2x 4GB disks. using it mainly for Plex and iTunes server.
i am now trying to install homebridge on it to manage my different homekit or non-homekit devices. as anyone tried it? any suggestions/hint on how to do it? i have not been able to install nodejs sofar, wondrring about how i could leverage Docker if it is even possible




I have never tried this. Let’s see if an experienced user can comment on this.

I used docker to get it installed

docker create --name=homebridge --net=host -e PGID=1001 -e PUID=1001 --restart=always -v /mnt/HD/HD_a2/docker-config/homebridge-config:/homebridge -e TZ=Asia/Phnom_Penh oznu/homebridge

Just check out oznu/homebridge

Hi… I tried to follow your instructions and those from oznu GitHub site, but I can’t make it work.
After installing using the following command:
_ docker create --name=homebridge --net=host -e PUID=500 -e PGID=1000 --restart=always -v /mnt/HD/HD_a2/docker-config/homebridge-config:/
homebridge -e TZ=America/Montreal -e HOMEBRIDGE_CONFIG_UI=1 oznu/homebridge_
, I have not been able to start the container. Every time I ran docker start homebridge, I got the same error message:

Error response from daemon: Cannot start container homebridge: [8] System error: exec format error
Error: failed to start containers: [homebridge]

(I also tried with root PGID and PUID, and without the Config UI)

Any idea why it does not work?


make sure when you copy and paste there is no additional spaces in-between each command, make sure the drive and time location is correct for your install and also make sure you removed the old docker container/image

You can learn how to remove container then the docker image from that link

docker ps -a

docker rm -f ID_or_Name ID_or_Name

docker images -a

docker rmi -f Image

when you create docker image you can use the sudo command as well so

sudo docker create --name=homebridge --net=host -e PGID=1001 -e PUID=1001 --restart=always -v /mnt/HD/HD_a2/docker-config/homebridge-config:/homebridge -e TZ=Asia/Phnom_Penh oznu/homebridge

then do
sudo docker start homebridge

I am actually using the “docker run” command as suggested on oznu/homebridge site, which tries to start the container after installing, and I have the same issue.
I am running docker as root, the config folder is own by root…
I cleaned both container and image before to restart the commands several times.

Still no chance.

2 quick questions for you:

  1. I can see you re using PUID=1000 : did you create a specific user to connect on SSH and run homebridge? (I am doing ssh as “root”)
  2. Do you have EX2 or EX2 Ultra? (I have Ultra)

I think its because you are using the arm processor

I have the PR4100,

try his raspberry pi version since that uses ARM processor

docker run --net=host --name=homebridge oznu/homebridge:raspberry-pi

Hey @kaiatkins,

Thanks so much for your help. I have tried the same @FabMtl was working on and per your last hint I tried the raspberry-pi version of oznu/homebridge. I got t installed both using docker run and docker start, both with and withoug sudo. In all cases though, I got the
Segmentation fault errors.

Segmentation fault starts to show up during installation of plugins… maybe there’s something wrong with that? As I also tried sudo it can’t be permissions, right?

does anyone fix this problem?

I unfortunately did not :frowning:

I ended up installing Homebridge without Docker and got it running!

@redtank How do you install Homebridge? I need to install Homebridge for controlling lights in my home. however I tried to install it with docker to mycloud mirror gen2. but I couldn’t. could you reply me how to do it? please help me

Back after a few month… never been able to install the docker version of Homebridge on the EX2 Ultra.
@redtank: could you provide more info on how you install Homebrdige with Docker on EX2?

Just wanna say thanks! This worked for me.

Hello all
Homebridge suddenly stopped working for (EX 2 Ultra) and I think that was caused by the last firmware update of the NAS (5.26.300).
Is anyone else experiencing the same issue? Homebridge still is installed and running but it gets into a loop error with the following messages:

s6-svscan: warning: unable to iopause: Operation not permitted
s6-svscan: warning: executing into .s6-svscan/crash
s6-svscan crashed. Killing everything and exiting.

Any ideas what is happening? I literally changed nothing else!

Trying to revive this topic.
Does anyone has any luck to run homebridge in a WD NAS machine? Please share, any information would be appreciated.

Add this to your stack on portainer:

      - seccomp:unconfined
1 Like

OMG THANK YOU SOOOO MUCH! IT WORKED IMMEDIATELY! I CAN NOT THANK YOU ENOUGH! After all this pain and suffering it was that simple? I feel such a lamer!

If anyone else looking to get Homebridge running in Portainer/Docker installed on CloudOS 5 that my docker compose command:

version: '3'
    image: homebridge/homebridge:ubuntu
    container_name: homebridge
    restart: always
    network_mode: host
      - homebridge:/homebridge
      - seccomp:unconfined

Hope that helps also someone else.

@lourencosv you’ rock!

1 Like