Home cloud, vs remote cloud

    • *> * * *
      TonyPh12345 wrote:
      It’s an “if” because some folks seem unable to get port forwarding to work with their routers. For most people, it’s automated via UPnP, others do it manually. The rest - well…who knows.

And yes, that’s what relay does.

 Really?

The only port forwarding problem my router has is for MyCloud apps from WAN,  port forward for ftp access to it works in LAN and WAN.

Additionally every other app asking upnp work flawless but MyCloud openvpn WAN relay. MyCloud apps works on LAN so i guess what doesn’t work is openvpn service or WD servers or both.

ill do some tests

If your phone/tablet is on your LOCAL wifi network at your house, it will have a direct connection to the WD MyCloud.

If your mobile device is NOT on your LOCAL network, you have to connect through the WD site.

The connection from your My Cloud to WD is an openvpn encrypted connection.

Login via SSH and you will see the OpenVPN client running and connected to one of these addresses:

WDMyCloud:/usr/local/orion/openvpnclient# grep remote client.ovpn

You can have multiple remote entries

#remote 10.101.253.100 1194
;remote 127.0.0.1 1194
;remote my-server-2 1194
remote orionrelay2.wd2go.com 14115
remote orionrelay1.wd2go.com 14948
remote orionrelay3.wd2go.com 14397
remote orionrelay4.wd2go.com 14137
remote orionrelay5.wd2go.com 14498
remote orionrelay6.wd2go.com 14077
remote orionrelay7.wd2go.com 14890
remote orionrelay8.wd2go.com 14221
remote orionrelay9.wd2go.com 14436
remote orionrelay10.wd2go.com 14516
remote orionrelay11.wd2go.com 14272
remote orionrelay12.wd2go.com 14812
remote orionrelay13.wd2go.com 14244
remote orionrelay14.wd2go.com 14783
remote orionrelay15.wd2go.com 14185
remote orionrelay16.wd2go.com 14575
remote orionrelay17.wd2go.com 14322
remote orionrelay18.wd2go.com 14882
remote orionrelay19.wd2go.com 14446
remote orionrelay20.wd2go.com 14584
remote orionrelay21.wd2go.com 14580
remote orionrelay22.wd2go.com 14150
remote orionrelay23.wd2go.com 14009
remote orionrelay24.wd2go.com 14594
remote orionrelay25.wd2go.com 14942
remote orionrelay26.wd2go.com 14931
remote orionrelay27.wd2go.com 14828
remote orionrelay28.wd2go.com 14345
remote orionrelay29.wd2go.com 14243
remote orionrelay30.wd2go.com 14180
remote orionrelay31.wd2go.com 14173
remote orionrelay32.wd2go.com 14322
remote orionrelay33.wd2go.com 14093
remote orionrelay34.wd2go.com 14500
remote orionrelay35.wd2go.com 14221
remote orionrelay36.wd2go.com 14603

Choose a random host from the remote

remote-random

MyCloud OpenVPN WAN relay? What are you talking about?

Did you see this thread about openVPN? http://community.wd.com/t5/WD-My-Cloud/OpenVPN/td-p/633179

Black is black.

… OpenVPN service is for… OpenVPN service.

No matter what port forward or upnp over WAN MyCloud uses OpenVPN tunneling.Uppps JRman post while i was writing…

You’re wrong, dude…

CloudNAS:~# netstat -aW | grep EST
tcp 0 0 cloudnas.tonyshome.net:microsoft-ds mars.tonyshome.net:54515 ESTABLISHED
tcp 0 132 cloudnas.tonyshome.net:ssh Tonys-iPad.tonyshome.net:52493 ESTABLISHED
tcp6 0 193 cloudnas.tonyshome.net:https mobile-166-147-068-xxx.mycingular.net:59531 ESTABLISHED
CloudNAS:~#

My iPad is on WiFi. My iPhone is on 4G (AT&T wireless, A/K/A Cingular).

If you’re going via relay, there’s something wrong in your settings.

Yes, the MyCloud makes an OUTWARD bound connection through your firewall to an OpenVPN SERVER @ WD site.

Look at the process:

WDMyCloud:/usr/sbin# ps -ef | grep openvpn | grep -v grep
root 20988 1 0 21:54 ? 00:00:00 openvpn /usr/local/orion/openvpnclient/client.ovpn

 

 

I have no such process running.

CloudNAS:~# ps -ef | grep open
root 11224 10734 0 21:02 pts/0 00:00:00 grep open
CloudNAS:~#

In the GUI do you have “Cloud Access -> Remote Access” enabled?

And what does it say for connection status?

Of course. That’s how I’m connected via the my Cloud app. Connection status is “Connected - Port Forwaring Connection Established”

Really?

I just enabled my pptp vpn on my tablet over LTE and launch MyCloud app.

Guess what??

I connects almost inmediatelly.

My vpn works better than WD ones. :slight_smile:

Ok, I just experimented with this some more.

I was not port forwarding from my router (I am using non-standard ports) to the WD Cloud Box.

Once I enabled the port forward at the router, I disabled/re-enabled the Cloud access.

No OpenVPN running now… I guess the openvpn is a “fallback” mode if you are not forwarding ports on the router.

Very interesting…

Tony is correct… 

I did some more test as there was a mistake in my previous result… When the drive is conected via port forwrding.

A remote connection to it via e.g the iphone “wd cloud” app is DIRECT…It does not go through any other server…

Well, the VPN debate aside, I wish I could do that on my apple devices!! Apple won’t send the Bonjour broadcasts via the VPN when L2TP VPN is up. My corporate firewall blocks normal access to my devices except for the one that’s on 80/443. If I could use the app via my L2TP VPN, it’d be brighter days. :slight_smile:

Heheh… I’m glad y’all followed up! You were making me doubt my sanity! :slight_smile:

Tony,
Would you care to explain when you said "Apple won’t send the Bonjour broadcasts via the VPN when L2TP VPN is up. My corporate firewall blocks normal access to my devices except for the one that’s on 80/443. If I could use the app via my L2TP VPN, it’d be brighter days. "

Are you talking about using the Wd cloud app?
If so, if your corporate firewall allows 80/443 then why doesn’t your app connect?

Looking at dashboard from tablet (using pptp vpn) : Cloud Access on Remote Access Configure » Connection Status Connected (Relay connection established) Port forwarding failed to connect on port 7080 and port 7443. My router uses port 80 and 443 for other thingd so i forwaded this 2 ports for mycloud. The “fallback” relay connection doesn’t work for me neither upnp. As soon i close my pptp client and try to use mycloud apps they stay at login…

Sammarbell, try putting your Wd drives ip in the router DMZ and see if gets a direct connection and not relay

Also try using ports higher than 60000

Alirz: it will connect, but only to the NAS that happens to be using 80/443. I have several other WD NASes that are cloud enabled, so they use other ports. I can’t connect to them. Since I’m using UPnP, it seems like whichever NAS boots first (like after a power failure) gets 80/443, and the rest get some other combination.