High traffic messages


I have a 4TB My Cloud connected to my home network. Wheever I’m ripping CDs from my music collection to the Cloud, I ge a high traffic message from my Netgear router. It is a gigabit router and one of the two switches I have it connected to is also a gigabit switch.

Under settings in the My Cloud dashboard, I see where the connection status is “connected- relay connection established”. I also see where it suggests a “UPnP option should be enabled on my router for best performance”. How do I go about doing that? I thought my router done that automatically. My router is a Netgear WNDR4300. I found something about port forwarding under the My Cloud’s manual. It suggests setting a specific port on the router (one for HTTP and one for HTTPS) for the Cloud. I don’t see in the router app how to do that.

Also, how come all my music tracks are listed as “other” when I look at My Clouds capacity usuage? My music is under the “shared music” in  the public share master folder.

WD web can’t show us how to port forward in every router avalaible.

Same for Upnp.

30 sec in google search chain “wndr4300 port forward”:

I.e. one of the first results:


For Upnp…Google it.