Here we go again... upgrade the firmwarre and Hub no longer completes compiling of library

Man - getting really tired of bad upgrades on this box. I had previously rolled back to 2.05.08 after having upgraded to 2.06.10 because the library would not compile on 2.06.10. After rolling back, library was fine and life was good…until the ISO bug popped up a week ago. Not fun when you have a toddler screaming for his Thomas The Train collection. So, I decided, since several new releases had passed since 2.06.10, that I would go ahead and upgrade to 2.08.13 - figuring that WDC would finally have solved most of the problems without creating new ones.

Sadly…since upgrading to 2.08.13, I can once again, no longer get the hub to complete the library compiling. Exact same issues as in previous post on 2.06.10 ( I’ve tried all the usual fixes, resets, limiting library size, eliminating file types - no joy. Looks like I’ll need to roll back to another safe load yet again (any thoughts on which one??) unless you all have any new ideas to try.

FWIW - I have my hub collecting the library from files stored on a Synology DS211+ NAS, with 2 2TB Segates in Raid 1 config. NAS & Hub are hardwired via GigE ports on a NetGear WNDR3700 (N600). I have a share setup on the NAS the only the hub uses and is limited to four folders (Music, Movies, Photo, Video). Even if I limit the size of the library by reducing the share to just the Movies folder (where the DVD files (mostly VOB and ISO) the library will not complete the compile. For some reason, anything after 2.05.08 and the library will not compile. Bizarre and annoying - especially since it worked very very well right up to the point of the ISO glitch. All files play perfectly fine via Windows Meida Center (including ISO files using Virtual Clone Drive for WMC).

Any thoughts? Roll back to 2.05.08, reboot on the ISO glitch and call it good? Man, one has to think WDC can provide better service than this. Honestly - my Linksys DMS-2100 was a MUCH MUCH better box - too bad it has limited file support and Cisco eventually killed support for it. Maybe it’s time to start thinking of a new piece of hardware…

I don’t know if you have tried this or not:

The below references using the Hub’s internal disk.   If that’s not where your media are, make the appropriate adjustments to the process.

The Media Library compilation can fail if there is media that is “crashing” the compiler process.

You can troubleshoot this way.

Step 1>
Connect via your PC and your network to map the Hub’s Internal Drive to a drive letter, say X:

Create a new folder called “.hidden.”

You will need to use the “DOS” COMMAND LINE to do it:

c:\documents and settings\tony
c:> x:
x:> mkdir .hidden
x:> exit

Now, open X: in Windows Explorer. You will need to enable viewing of “Hidden files and folders”.

Step 2>
Move ALL of your media into that hidden folder.

Reboot your hub.

Does the media library finish compiling? (It SHOULD, because there’s not supposed to be any media now.)

Step 3>
Now, move small amounts of your media OUT of the HIDDEN folder back to where it was bofore.

Reboot your hub.

If it COMPLETES compiling, go back to Step 3 and keep repeating.
If it does NOT complete, then you know that the issue is with one of the files you just moved.


I don’t know that you’re going to want to wait for a firmware to “fix” your issue, because as far as I can tell, very few else have the issue, so you’re going to be hard pressed to get WD to look into it.

You can file an issue report and see how many people comment on it, though…

Incidentally, my Hubs (2 of them) are connected via Gig, and the other is Wifi, to a QNAP NAS with 8TB of storage…  As of last count, I have 76,000 files on it that the Hubs have to sift through when compiling.

I also have a WD MyBook Live 1TB that I keep my music collection on, and when I “Fake Link” it to the QNAP such that it all looks like one ginormous share, the total gets closer to 100,000 files.   When I Fake Link my Win7 box (which has all my family photos on it) the number then exceeds 125,000 files.

Of the 100,000 number, about 35,000 of those files are the media files themselves, the rest are the associated metadata, thumbs, etc.

The Hubs take about an hour to index it…  and it works every time.

Both of my hubs are running 2.08.13, but never had any issue on any prior release, either.

I have tried this back with the 2.06.10 release, in a similar fashion, by hiding all the shares for everything but the movies (net result, the hub only sees the movies folder and no other files - essentially same as hiding them). I then moved all the movie files to a different folder that the Hub cannot seem, and brought them in one at a time to see if it would compile. Here again - no luck. Hence I rolled back to 2.05 and it seemed to work.

I’ll try it again tonight with 2.08 and see if I get different results - but I am not expecting much at all. The question has to be asked - why would it compile every time with 2.05 but not on any releases after?

…So you’re saying when you did the test, it failed to compile even the FIRST MOVIE you put on the share?

I suspect that with each later firmware it might look at more of the ID3 and MP4 tags inside the files to build the database.

The database itself also contains additional data from one version to another.