Help with Windows 7 - Mycloud not accessible in explorer

I bought a Mycloud 3TB two weeks ago.

My config was until today :

  • laptop, win 7 64 home edition

  • desktop, win xp 32 sp 2

all connected through my modem/router

Everything was fine using DHCP (IP

Now I changed the OS on the desktop to a Win 7 64 Integral edition.

And I can’t browse the mycloud drive anymore.

Quickview finds it, I have no problem to access the dashboard.

But everytime I try to find the shared folder, using the shortcut created on the desktop by Quickview (\MYCLOUD\Public), I have the same error:

Code 0x80070035

Network path couldn’t be found.

I already tried to give it a static ip, to change the WORKGROUP to HOME, completely disabled the Windows’ firewall.

Everything worked nicely on the laptop, which found the NAS immediately after rebooting. But no chance at all on the desktop.

I suppose it’s a Win 64 issue, but what to do ?

Can someone help ? Thanks

Just forgot to add that using the network diagnostic option doesn’t help, as everything seems to be fine according to Windows.

Also, if I try to connect the Mycloud device directly to the desktop, it won’t find it. When with the home edition, it got found automatically. Yet accessing the dashboard works.

Last but not least, Mycloud appears in the Network section of Explorer’s left pannel.

But I just can’t browse the share. Network error, network error.

P.S. Sorry for double posting, I found the “edit” option too late.

Call their tech support snce you only bought it 2 weeks ago. You get 30-days of free phone support. 

Go to the windows credential manager, in the user accouts and family safety control panel. Delete any stored credential for your NAS there.

Disable any backup, sync or other software that might access the NAS with some credentials.

Unmap any drive (you can also launch a command prompt and type net use * /delete

Reboot the computer

Remember that each Windows user can only use one set of credentials to access all shares of another computer (the NAS in this case). So once you have access your NAS with one set of credentials, you cannot use another set of credentials.

1 Like

Thanks for the help. But I got the same results.

I uninstalled the device in the network section of my explorer, and when I reinstalled it (right-click on the icon/install), I got an error message (couldn’t install a driver for the device).

I tried to install the software provided with the nas, and I got all the errors (can’t access files, can’t access shares, all red crosses).

I installed SmartWare, same network error.

It works with the laptop and worked with XP, without any driver.

Do you have any more ideas, by any chance ?


It was the “NETBIOS Assistance” service that had to be activated.