Help with WebDAV

I’m trying to access my files via WebDAV and I’ve done all that is required (extracted username and password from orion.db file etc.).

Now the thing is, when I use try and login, I get a “method not allowed (status 405)” message.

Could you please help?

[I own a My Book Live as well. Using the same steps, I’m able to login to My Book Live via Webdav but not into My Cloud. Please help!]

It is entirely possible WD disabled WebDAV in the OS3 firmware when they supposedly dumped WebDAV on the WD2Go/MyCloud website portal. One may have to poke around with SSH to see if it can be reenabled if disabled.

thats so sad!

Goodness me, this is just deliberately curbing user options :frowning:

I have an old My Book Live and webdav works perfectly with that.

I’ve created a patch to bring back drive mapping but only tested on my dev environment running the latest OS3 firmware. But my main firmware is still the outdated v4 no time to upgrade. I will only release it when I upgrade to OS3 because it needs to be tested throughly.

Hi Nazar, was hoping you’d reply :slightly_smiling:

Thanks for the update regarding this. I’m also running v4 and thought that was the latest version. Anyway, do keep us posted. Thanks for your help.

Hello @troubledchild,

Apologies I completely forgotten about this thread not till yesterday I was meddling with some similar settings. I’m actually using WebDAV with Nginx and till now I’m still using the old v4 firmware :frowning:

What I’ve done was I created a so-called patch to allow manual drive mapping (do we still need that java applet thingy?), using the existing user/group which must be running in SSL due to the base64 hash authentication. I’ve tried MD5 digest but base64 seems to work way faster and more efficiently. Also initially I tried using PAM but that was too slow for deep paths, MyCloud is not that fast.

From my end it works as I expected, just need to tweak a few here and there then finally build the package. It seamlessly integrates beneath the WD Dashboard where you can add/remove users/shares and all will be visible in the drive mapping using the existing accounts (not the MD5 hashed accounts from the orion.db, which according to @Bennor from a previous post, is now empty). You could map locally or externally using the existing WD DDNS or even browse from the browser i.e. locally https://internal-hostname-or-internal-IP/internal-hostname or externally[:SSL]/internal-hostname.

But I’m not sure the outcome in OS3 as my dev environment is staged. Below are some of my concerns:

Has WD completely removed drive mapping from the OS3 firmware? What happens after you login to Can you see your files, upload/download/edit them from the portal? Or are we left using the WD desktop/mobile apps? I can’t proceed anything after login to the portal, there’s a line asking to upgrade IIRC. Though, I could still login remotely using the android app.

It would help me quickly revise the changes needed if someone could go through with me the differences, or possibly let me hands-on the OS3.

WD removed the drive mapping feature from the web portal. One can still upload/download and email/copy links to files. But the ability to map the share is gone. With the WD apps/software the same. Remotely one can upload/download files (depends on the app/mobile platform though if one can do all files or just photos). Bottom line is there is no current official WD supported method of remote mapping that they’ve provided to replace the removal of the remote mapping when they revamped (now

Thanks for the info @Bennor.

Hope that WD will not make any other drastic changes. I think I’m done with the mod, just need to compare several files/data that I can’t stage in my dev. If anyone could assist please pm me thanks.