Help with SMP and Network Shares (2008 R2)


I have a WD TV Live SMP connected to my LG TV, hardwired 100mpbs connection.
Firmware 1.09.10
The device is unable to locate any PCs or shares when selecting a Windows Shares Content Source.
The media is stored on a Server 2008 R2 EE DC.
In an attempt to resolve this I have tried many combinations found in other posts.

Currently, the firewall is disabled, SSPD enabled, Computer Browser enabled, uPnP Host Device enabled.
I have selectively enabled NetBios over TCP/IP on the teamed NIC.
Network Discovery is “Turned On”.
“Everyone” has both Read NTFS and Share permissions.

The device workgroup is set to “DOMAIN” and the AD domain is  “DOMAIN.NAME”.

 DC/DNS is at, Gateway is at, device is at

DHCP is provided by the router.

Net View:


nbtstat -a Server

SERVER            <00>  UNIQUE      Registered

DOMAIN       <00>  GROUP       Registered

DOMAIN       <1C>  GROUP       Registered

SERVER            <20>  UNIQUE      Registered

DOMAIN       <1B>  UNIQUE      Registered

DOMAIN       <1E>  GROUP       Registered  

DOMAIN       <1D>  UNIQUE      Registered

…__MSBROWSE__.<01>  GROUP       Registered    

Net Group:

*Domain Admins
*Domain Computers
*Domain Controllers
*Domain Guests
*Domain Users
*Enterprise Admins
*Enterprise Read-only Domain Controllers
*Group Policy Creator Owners
*Read-only Domain Controllers
*Schema Admins

Net Share:

IPC$ Remote IP
C$ C:\ Default share
D$ D:\ Default share
print$ C:\Windows\system32\spool\drivers Printer Drivers
ADMIN$ C:\Windows Remote Admin
B d:\B Backup Files Stored on Server
G d:\G Game Files Stored on Server
M d:\M Music Stored on Server
NETLOGON C:\Windows\SYSVOL\sysvol\\SCRIPTS Logon server share
S d:\S Software Files Stored on Server
SYSVOL C:\Windows\SYSVOL\sysvol Logon server share
V d:\V Video Files Stored on Server

The share is a single folder for music, //server/m/Album/*.mp3.

Any help on this?
Thanks in advance.

Did you change the workgroup name of the WD to “DOMAIN”?

Yes, I would love to get this to work so I can drop PMS and use a nice theme to get an XMBC ish setup.

I have now also tried enabling the Guest domain account and giving it specific NTFS and Share Read permissions.  

I have also created a share on a Win7 box, enabled network discovery, disabled firewall, provided “Everyone” with Read NTFS and Share permissions.  Still not change.


Manually setting the IP has fixed it.

I will now back off all the extra settings I tried to see what is really required.

I have now disabled the Computer Browser service.  Disabled the Guest account.  Removed the manual Guest entries for NTFS and Share permissions.  Removed “Everyone” from NTFS and Share permissions.  Added “Authenticated Users” to Share permissions - Full Control (to use the generic media account my other media servers use)

I can only assume the issue has something to do with my Cisco 3725 router config as the only thing that changed was me setting the IP manually vs DHCP. (Even though DHCP pushed the correct mask, gateway, dns and a valid IP).

As a reference for others, I have now stopped and disabled Computer Browser service, SSPD Discovery service, uPnP Host service.  My firewall is enabled.  Network discovery is turned off.

The Share permissions are set for “Everyone” Read-only however I am using an acount with admin rights (same acount used for SickBeard post processing - needed to batch copy files across the network).

So all is well and the only thing I needed to do was manually set the IP.  Weird.

So glad I found this post. I’ve been fighting to get the shares up on my WD TV Live Streaming for a few days. I have a nearly identical setup to you however DHCP is coming from my 2008 R2 EE box. Once I set the IP manually in the WD TV the shares came up right away. All the IP settings are the same, just set manually. Go figure.