Help with router connection/ continuous spinning

When I check the dashboard settings for the “connection” it says “Connected (Relay connection established” and below that says that “For best performance, enable UPnP on your router to establish a direct connection”…I have tried to follow the directions to make sure that my router is properly configured (it’s a Netgear).  I followed the link for the type of router.  One of the first few steps I believe says to manually input the IP address for my drive but when I go to the page to do that, My Cloud drive is already listed with an IP address.  Then I went to the advanced setting tab for the router to the UPnP tab and made sure the “enable” square was clicked – nothing changed…every device I have shows connection via relay connection.  I don’t know what else to do…I feel like I’m going in circles.

Also,is the drive supposed to continuously spin?  I haven’t heard it stop, even when nothing is connected to it (except for it’s connection to the router).  Am I supposed to be turning it off or is it supposed to continuously run?  Also, with the spinning, there is a very, very faint but rapid “tap, tap, tap, etc” and it is warm.  I don’t know how warm it is supposed to feel to the touch and since I can’t get my Quick View to work at all, I don’t know how warm it actually is or if it’s operating properly.  If I am supposed to turn it off, how do I turn it back on?

Oh, one other thing…what in the heck does “mapping the drive” mean and what does it do?  I’m assuming it’s good but if I don’t like it, can I undo it?

My apologies if I’m still not posting these properly…these forums are supposed to be to help computer retards like myself, but if you are tech illiterate, you don’t usually know how to do the forums either.

A realy connection will be slower than a direct connection. It looks like you already have enabled UPnP on your router. What you should do is use your router to assign a fixed IP address (it can be the current one). This will prevent the NAS to request an IP address to the router and maybe receive another IP address, which could throw off several access services.

To assign a fixed IP address to the router, check your router instructions. Typically, there is some table in the DHCP setting where you can create rows indicating which MAC address (linked to device) should have which IP address. Choose an IP address outside of the DHCP range of your router. For example, if your DHCP server distributes addresses in the 192.168.2 to 200 range, change that setting to the .2 to .199 range, and give the IP to the NAS. Reboot your NAS. YOu might have to update shortcuts to the NAS so that they points to the new IP address.

Once this is working, check whether direct connection is enabled. Again, this is not a big deal…

Mapping a share to a network drive makes it easy to use the NAS shares directly from windows explorer and with Windows applications. You can easily disconnect any mapped drive.

Thanks but I’m not sure I understand what/ how to do what you said.  I will look at router instructions again…also don’t know how I can tell if an IP addressed is a “fixed” one or not.  It also looks like changing a lot of other things that are getting way too involved for me…I thought this My Cloud was supposed to be a simple, easy way to access/ save my stuff, but it’s becoming a lot more complicated than I wanted.  I’m not comfortable having to go in and change IP addressed for everything on my network – what may be a piece of cake for some would take me forever.

If I don’t map the drive, then how am I accessing it if not through windows explorer?  It (eventually) shows up under my network when I click the “computer” icon. 

And, can someone please explain whether or not the drive is supposed to continuously sound like it is wroking or being accessed?

I tried this approach and I still had many problems with security and remapping of drives.  I told the router DHCP service to assign a specific address to the My Cloud device.  The device kept this address over multiple reboot cycles of ALL my computers and router.  However, I could map a drive, reboot the computer and when the computer came back up the mapping was lost.  This was 100% consistant across 2 tower PCs and a laptop.  Loss of mapping.