Help with network sharing (not from Windows)

Hi! I have a modem/router with USB port and it can share the content using samba. The router let me create users with passwords and share to the network.

My windows PC can access the router content fine, but my WD TV Live can’t access, can you help me?

My router model is TP-Link TD-W8968.


are you the same user “Irhlpz” over at

if so, you’ve already get my beta firmware running

you can use xmount to bypass WD’s smb implementation and access the share under local drives

there’s a wiki page about it

but of coarse, if it’s just a coincidence that you have the same user name then ignor the above

and we would need additional info, what actually happens

does the WD just not see the router or does it give you an error message when you try to access it, what error message do you get

Thanks! yes, the same user :smiley:

My router use a netbios name with space (“ADSL ROUTER”) and my WD TV Live can’t connect. I’ll try the custom firmware method.

Have you already tried a name without white space?

I agree that having a space in the netbios name is just a bad idea

there’s plenty of systems out there that will not function correctly with spaces in the name

Trying to completely understand your question/comment.  If I understand you correctly, you are able to connect a drive to your router USB port.  Your computer can see the contents and the WDTV can’t.  Correct?  If so, I have the same issue with my Asus router and it’s attached drive.  I think the router is not sharing the drive correctly, either as a media server or network share, because the WDTV says there is no media content.  I have other devices (other than WDTV) that can’t see the content, too, and some that can.

I can access from my windows only using the ip, not the network name of my router. For example, on windows 8, wirtting \\netshare works, but \adsl router\netshare is not working (there is a space between adsl and router). WD TV Live only show “adsl” as network name, not “adsl router”, that’s the reason I can’t access my router network shares, and I can’t use the IP number as on windows.

At the end, using the net.mounts method works.

that why it’s suggested to remove the space in the name so something lie adslrouter or just router etc would have likely solved the issue

but net.mounts yeah will work with spaces, because of the enclosure in quotes “adsl router”

linux reads spaces as a field separator

so adls and router are 2 separate items

but in quoted “adsl router” it’s treated as a single item

anyways glad it working :slight_smile:

I used the ip number with net.mounts, I think it is better than the netbios name. Sadly I can’t change the netbios name of my router.