Help with file rip formats and audio for 1080p movies with older 5.1 reciever

Hello,

 I just started ripping my BluRay to be played on my WD TV Live Streaming. 

Tools I have are HandBrake and DVDFab Blu-Ray ripper.

I can create m2ts and mkv files that work just fine on my PC with VLC.

I can play the BluRay disks just fine on my PS3.

My hardware is a bit of a kludge.  I have a older DTS & Dolby Digital 5.1 receiver that takes optical in and SD video.  These are the first iterations of DTS and Dolby Digital and does not support the new BluRay HD audio.   To get around buying a pricey new surround setup I have added two items.  A 4 to 1 HDMI switcher and a HDMI Optical break out box.   It works great with DirectTV in HD, PS3 including BluRay movies, XBOX, and most things with WD TV Live STreaming. 

I have been playing DVD ISOs with network shared from my Win 7 PC without too much issue that I cannot figure out a way to get around if there is too much disk protection by ripping out the main movie. (LAN connection not WIFI)

My problem now lies in getting 1080p movies to play audio with the WDTV Live Streaming.   I think the issue is my older receiver does not like the HD Audio as I hear nothing from my 1080p MKS and m2ts rips of my BluRay movies.  I have tried several setting in Handbrake and DVDfab without success in being able to hear audio.

I have found a couple of anime movies on the web in 1080p that plays just fine.  Audio and all.   So I don’t think WDTV is to blame at all.   VLC says MPEG AAC mp4a and AC3 stereo audio streams on one and MPEG AAC Audio mp4a on the other. . This leaves me with trying to find the magic AUDIO format to convert to for my setup.  

I have no interest in saving disk space by compressing the video.   That is not my problem.

I have tried the following in DVDFab.

m2ts.default with Audio set to 448 kbps bitrate and 5.1 multichannel and stereo

checked the Remove HD Audio checkbox.

m2ts.ac3.normal

m2ts.passthrough

Handbrake I have not tried yet as I need to rip to a interim video format.

Has anyone a solution with Handbrake, DVDFab, or other free program that can correct the AUDIO for older DD DTS receivers with limited bandwidth?

I would like 5.1 if possible.   Best quality would be my older DTS supported format .  But at this point I think I would be happy with anything even stereo.

Thanks

Scott

You can check the link below for the list of supported audio codecs. Also check if selecting the Digital Pass Through helps.

http://wdc.custhelp.com/app/answers/detail/a_id/2698/session/L3RpbWUvMTM0ODQzMDEwNi9zaWQvUTN5N0ctNmw%3D

http://www.wdc.com/wdproducts/library/UM/ENG/4779-705062.pdf#page=179

Hi

Do you get any sound by letting the SMP processing the sound on the TV?

I dont think the SMP supports HD Master sound. Probably a passthrough would work…

I dont use handbrake.
You can transcode the audio in your mkv/mp4/m2ts files easily with a freeware tool called Hybrid. (link below)

-video passthrough

-audio custom

-Drag & Drop the file into the Input File line

-on the audio tab try DTS or ac3 encoding with a bitrate that your HW support. The SMP does NOT support multichannel AAC encoded audio!

  • with the “+” you add the encoding to the audio queue

-Main tab: Set output file

hit “Add job” and start the job on the Jobs Tab

You can also set unprotected BluRays as input.

The default output container is MP4. you can change this in the Config tab.

The SMP does handle MKV and MP4 equal good. MKV have some advantages like forced subs, but on the end it depends on your personal preference what container you use. m2ts is very limited.

Hybrid:

http://www.selur.de/downloads

Thanks

Will give this a try.

-Scott

I’m using MakeMKV to rip my BluRay’s and HandBrake to re-encode them to significantly smaller size without picture/sound quality sacrifice.  MakeMKV is straight foward rip that generates a huge .mkv file and may be fine if you really don’t care about the size. In Handbrake, here are the setting’s that I use for 1080P/5.1 DTS. I also have an older stereo that only has optical and I hate not having DTS from a BluRay rip.

Handbrake Settings:

  1. Picture Tab: Presets -> Regular->Normal; Container ->MKV File;  1920x1080

  2. Video: Video Codecs H.264; Framerate Same as Source;

  3. Audio: Source ->English (DTS) (5.1); Audio Codec->DTS Passthrough

Hope that helps