Help with a failed enclosure


#1

I have a 1TB World Edition II drive (blue rings) and all of a sudden won’t turn on.  Tried a different outlet, pressed the reset button, opened the drive and reseated the drives and no luck.  Also, tried a different power supply.  I noticed the ethernet light in the back comes on, but the front rings are not responsive.

What can I do if it is out of warranty?  I had it in RAID1 configuration (mirror) and want to get the data off of the drive.  I tried to connect to my Windows computer and using an external SATA to USB cable and didn’t show up.  I also tried using Ubuntu with the same results.  How can I get the data off or use the drives in another enclosure??

Your help is appreciated.  Thanks


#2

I’m having exactly the same problem as this person. Is there any solution from WD on this issue?


#3

Since there’s been no replies, maybe you should try contacting WD’s Technical Support about this. You can do so either by phone or email.

To Contact WD for Technical Support
http://support.wdc.com/contact/index.asp?lang=en


#4

I’ve had my My Book World Edition II (blue rings) for three years + one month, no problems…until now.

I have the same problem as above, it won’t start.  (I turned it off when I left for vacation and it won’t turn back on.  It did come on once, I was able to read and write to it, then the rings started blinking alternately.  I turned it off, let it cool down, and now it won’t restart.)

I tried taking one drive out and starting with only one drive (first A drive, then B drive), but no help.  I tried plugging the power supply directly into the wall, no help.  As above, the ethernet light comes on, the power supply cord light comes on, but the enclosure does not come on.

Any suggestions?