[HELP] WD TV Hub dont work anymore and always turn off

Something happend but I dont know what.

When I power on the Hub by pressing tu power button of my remote, I have the WD logo of the hub who stay light and appear on my tv the WDTV Hug logo. after few seconds, my TV become black screen. Then after few secondes again, my tv show again WDTV Hub logo, but the logo of the WDTV box become to blink ! and then the WDTV box turning off…

I don’t know what happend, I did nothing … I have many datas, I need your help to first try to fix the problem and maybe if not possible before using warantee, retrieve data.

I already pressed reset button but no effects, and unplug power during 10 minutes and plug it but still no effect !

Thanks for reading me, sorry for my bad English.

I hope you’ll advices to help me.

Ok I read many posts who talk about my problem …

But finally I dont know what I have to do ?

The best way for WD is that I ask to have the right to open my Hub to extract my Hard drive to save data to my computer and then I send my Hub to WD support ?

Please give me the best way.

I know a little electronic, so maybe I can fix the problem by myself ?! What is the best way ???


So as other guys did !

I opened easily the box.

Then I unplugged the cable to the wtich button board with a thin pincel, and that’s all.

Now it’s working.

What about next firmware update or other update ? May I have a problem to install it if I dont have the power button board connected to the main board ?

Thanks again for reading me, and sorry, I found a “solution” alone by reading all other messages !

Thanks to the community, I’m waiting answer from WD Staff about next updates

The absense of the power switch, other than voiding your warranty, won’t have any other effect on the box.

Firmware updates will work normally.

I fixed my box!!!

You can check out my video, if you haven’t fixed it yet.