HELP: WD 2TB NAS Crashes and needs a Hard Boot, when doing a large data transfer

I have had the WD 2TB NAS My Book World Edition II for couple of months.

Everything works fine till the time a huge data is being transferred over the network to the NAS. Huge data means to say anything above 100GiB. At the time transfer is going on, the NAS after some time stops responding over the network. All the Windows OS reports that it’s no longer available. I can’t ping to it or SSH to it.

After I plug it out and then plug it back in it’s comes up normal. I checked the  LOGs on the NAS, and it doesn’t seem to have any issues reported on the LOG, just the last one which says there was an abnormal shutdown “02/20 20:46:01  WD-2TB daemon.warn wixEvent[4768]: System Abnormal Shutdown - System had abnormal shutdown last time.” I don’t have any options other than a Hard reboot, tried all possible actions.

Firmware Version: 01.01.18 with MioNet  built on Wed Dec 2 15:55:04 CST 2009

Space: 70% full

Earlier it was happening once or twice a month, but now I tracked the issue and it seems to be happening more frequently, only when there is a large data transfer over the network to the NAS.

Being little knowledge and working in the field of IT, I feel the kernel of the OS crashes making everything hang.

Is there a FIX for this?  Can I put a watchdog somewhere to detect and log the crash event?

Please help.


Have look at this…

Also update your firmware. Good luck M

The link does not open. Gives me Error: Forbidden Access.

ive tried several things w/o luck. (disable mionet, etc.) im not going to update f/w because itll probably screw something else up. ive just learned to deal with it. maybe its the green drives that are in this thing that are the problem…

The thread is at the top of the page. Wd world edition white light freezes/locks up is the title. The link now works Good luck M

Have you sorted you problem out

i had already tried what was in that post w/o luck. it still froze up. currently ive trying one of the sub posts in that topic that says to remove the “nice” command and ive disabled mionet as i know that causes my book to freeze from experimenting. im transferring 64GB to the my book to test it and its made it further than i can remember in quite some time. hope i didnt jinx myself though?! ill update later.

030811 update: the 64GB upload was a success!! i think we may be on to something here. here is a snapshot of what i did.

  1. followed LarsMaschke post to remove “nice -n -20” so that it just says " /usr/sbin/smbd -D"  in /etc/init.d/S90smbd.


  1. followed Vlado post to disable everything mionet (I didnt do mv /etc/init.d/S97twonkyserver /root which deals w/ twonky) and i also edited /usr/mionet/ to make Mionet obey startup flag.


  1. reboot through putty and/or web interface.


i had undone everything else i’d tried on the forums here so truly mionet is the only thing disabled.


I disabled the twonkey and the mionet for now and not tested it so far. Will update this thread as soon as I get the crash.

After diagnosing with experts in Linux and Busy box, I could find out that the there is a kernel crash and not the WD app crash, because of which the box does not respond on any of the communication points and has to be hard booted.

Something similar is happening in our office too with our devices, where, when there is a heavy traffic to the device the Linux crashes and after investigation we found out that its the Network driver issue in the Linux.

I don’t know if the WD is having the same issue, but the symptoms are the same.

Will test and see if my WD freezes up again.


BTW: I am still getting Forbidden Access to the link provided. I am logged on to the site.

They this one. The last link is the same as this but as the  thread move down the page for some reason you cannot access I have the same problem it seems only to effect this link. Mind this thread is only a couple below yours. Good luck M

Thanks for the link again. Some how I was not able to access it earlier.

I did Disable Twonkey, Mionet, Initd and the nice command from smbd. now lets see if this survives for how long. I’ll start tonight 1TB transfer and see if it still survives.

One question I had. After seeing the memory by “#cat /proc/meminfo” i got the following:

~ # cat /proc/meminfo
MemTotal:       126828 kB
MemFree:          2536 kB
Buffers:         88112 kB
Cached:           6360 kB
SwapCached:          4 kB
Active:          70168 kB
Inactive:        35004 kB
SwapTotal:      256888 kB
SwapFree:       256876 kB
Dirty:               0 kB
Writeback:           0 kB
AnonPages:       10708 kB
Mapped:           5568 kB
Slab:            15724 kB
SReclaimable:    12544 kB
SUnreclaim:       3180 kB
PageTables:        580 kB
NFS_Unstable:        0 kB
Bounce:              0 kB
CommitLimit:    320300 kB
Committed_AS:    67392 kB
VmallocTotal:   253952 kB
VmallocUsed:       516 kB
VmallocChunk:   253380 kB
~ #

My Question is, if you see the free its too less and if you see the buffers and the Inactive that’s quiet much. Why is the free so less ? Due to so less of memory free will the device not freeze if something demands for more memory like file transfers?