Help viewing FAT32 files that I backed up after I reformatted to NTFS?

I first purchased the My Book Essential about 2 years ago.  At the time I had a laptop running Windows Vista and a desktop running Windows XP. I ran my first backup on my laptop, straight out of the box, which I believe was using FAT32 format.  When I tried to back up my desktop, I received a formatting error.  I got frustrated and set the My Book aside and didn’t touch it until a couple of days ago.  My laptop was stolen before Christmas, so I now have a different laptop as well as a desktop.  Both of these computers use Windows XP.  The first thing I did was move the backed up files from My Book to my new laptop.  Then I reformatted the My Book from FAT32 to NTFS.  Then I moved the files back to My Book.  Next I backed up my new laptop.  Everything seemed to be fine until I tried to open the files from my very first backup.  I can’t open them.  Is this because they are FAT32 format?  If so, do I need to format the drive back to FAT32 in order to view them?  I hope this all makes sense…sorry for any confusion (first time here.) 

My Book model #: WD6400H1U

Thanks in advance for your help!

Should not be an issue, when you transfer files in FAT32, to a system running NTFS, files are automatically converted to NTFS and vice versa.  Your problem sounds like data corruption, do you receive an error when you try to access the files from My Book?

It will be also helpful to run an Extended Test to your drive: How to test a drive for problems using Data Lifeguard Diagnostics for Windows

1 Like

Thanks for the response.  No, I do not receive any error messages when I try to access files from My Book.  In fact, the recent back up I did on my new laptop appears to be fine.  I just can’t seem to open any of the files from my first back up. 

I also wanted to mention that when I installed My Book on my laptop, it automatically used Memeo AutoBackup to back up my files.  Could it have something to do with that program?

I suspect the files may be corrupt because FAT32 is more prone to corruption. I don’t really know if they can be fixed. Maybe this will help   You can try burning a Linux Live CD and see if you can access the affected files and if they open try save as instead of copy or move. The only other thing I can think of is to make a FAT32 partition and copy the affected data there then try converting it to NTFS

1 Like