HELP, Usb not working after installingmybook live

I installed a mybook live 1tb and now the usb on my laptop doesn’t work and it has a fatal error and reboots windows every 20 minutes or so. It flashes a message about powerstate failure and then shuts down. None of the usb ports work. I have trieds to uninstall the software but it hangs and won’t uninstall. I contacted WD support and they said to update software, which I did, butit son’t update firmware. This is totally frustrating, and I wish I had never purchased this product.  Any ideason where to turn now?


I don’t understand something. The MyBook Live only has two connectors. Power and a Gigabit network connnection. You’re stating that your USB on your laptop is not working?

You need to elaborate on exactly what you did, not omitting any details however trivial, that worked up to your laptop’s USB ports failing.

I purchaced the product and installed the software as instructed. As a part of the installation,the installer informed me that an update was availalbe and I clicked to install the updated version. After installation, everything with the mybook worked fine, It was installed at my router in another room. However, my laptop, which is connected wirelessly lost the usb connectivivty and the power state failure problem began.  It reboots my laptop every twenty minutes or so,but only when I’m not working on it… like when it’s in a hibernation.

I got frustrated and unplugged the mybook at the router, and the laptop’s usb functionality returned and it stopped the rebooting. I have tried to uninstall the software, but I get an error message stating that there was a problem with the installer and it terminated the uninstallation. Oddly, all the other computers in the system work fine and are able to access the mybook with no problem. My laptopis a toshiba Satellite psaxou-008004 running windows 7 X64.

Windows states that the UMBUS.SYS stops working.  The happened 364 times between when I installed the mybook and I unplugged it.

Hope this helps explain what’s going on… Thank you .

The MyBook Live does not need any additional software to be able to work with your laptop. are you trying to state that when you installed Smartware which comes with the MyBook Live that your laptop has gone faulty?


Yes that’s exactly the case. I know it’s really wierd and it doesn’t make any sense… but I did everything that I could do, but I’m afraid to hook the my book back into the router. My laptop seems to be back to normal now that it’s unhooked.


Unnstall all instances of Smartware from your laptop. If you still can, maybe use (I assuming it’s a Windows laptop) System Restore to remove Smartware then reconnect the MyBook Live.

The MyBook Live is a network device. It’s purpose is to appear as a computer sharing storage resources. It does have other facilities like Twonky media server, iTunes server, remote access via. WD2go and also an FTP service if you don’t want to use WD2go.

I honestly can’t see the device itself causing USB problems on your laptop.  Maybe Smartware is causing the problems?

It’s certainly a puzzle.  Trying to keep the solution as simple as possible here and the simplest possible solution is to plug the MyBook Live into the network and DO NOT install any software on the laptop.