HELP! Updated firmware and lost ability to save files from SMB

So I might have messed up my MyCloud. All I changed recently was the firmware. I just updated to the
Everything worked great until this. Now my SMB users can’t write data to their respective shares. I have a dashboard and SSH and have looked at it from every which way but can’t for the life of me seem to solve this. I have checked the permissions on the shares
ls -l
and they are good
so I checked samba, I have looked at the conf files for

All seems to be ok. My conclusion was that it must be a bad firmware flash. So I downloaded the .deb and logged into the dashboard and when I went to manually upload the firmware it is stuck at 0%

Not even the dashboard has privileges to write to the HDD. So then from SSH I did a wget of the firmware to the public folder in /DataVolume/shares/Public and tried to use the /usr/local/sbin/ command to install it and it came back with an error saying that the firmware wasn’t compatible.

I’m out of options and looking for help. If you can think of something I have missed please run it by me as right now the only access I can get is read only on everything unless I SSH into the box.

@nate9000 What computers and operating system are you using? If all are Windows 10 you may want to check this.

I use all kinds, Win 7 & 10 Linux(debian, ubuntu, SUSE), ChromeOS, and Android. It is the exact same issue from all devices. They can sign in and read data but can’t write data even when SMB has them in the "write list = " I also have a global Writeable = yes.

Are the Shares configured for Public or Private in the My Cloud Dashboard?

If they are set to Private, try setting them to Public and see if you can save files to the Share.

Do not try to modify the SMB config files via SSH as the My Cloud Dashboard may overwrite your changes or you may cause a conflict with the My Cloud Dashboard. All changes on Share permissions should be made through the My Cloud Dashboard. And absolutely do not issue an “apt-get update” command through SSH. On a first gen v4.x My Cloud an apt-get may brick the My Cloud due to WD using a different page file size on their custom Linux firmware.

As another troubleshooting step try performing a 40 second reset to see if that might fix the problem.

All are set to private. I did change the public share to test it and its the same thing. after making it full access for my user in the dashboard it still comes up and lets me start the transfer but no data is written.
I don’t think anyone ran an apt-get on this HW but if so is their a way to check that the Samba version installed is still 64k compliant. Or dose all of that get written over again with a firmware update??

I am open to complete reinstall of the firmware provided it dosn’t kill my system shares.

Well just a side note, I just did the system reset from the dashboard. I have put all my users back in and linked them back to their appropriate shares in the dashboard but I still can’t write data. Users sign into the shares following all the proper permissions but I still can’t write. Can anyone tell me if the System restore option in the dashboard reinstalls all the OS stuff or is it just resetting the settings from WD. I have a feeling that the SMB server was updated via apt-get and thats the issue any recommendations to reinstalling the proper 64k ver without losing my data.

I believe that the 4k version will not work on the on the My Cloud. If you check what processes are running. You should see smbd and nmbd processes. If you do then you have the 64k version.

oh then its definitely the right version then since I can see it running and it lets my users sign in. I still don’t understand how just updating the firmware stopped me from being able to write data to the file shares. I have also checked the smb-gobal.conf to make sure that the “force group = share” is set.

Can anyone tell me if there is a way to full install the firmware instead of just update and keep the user data (/DataVolume)

Try to use SSH and look at the shares and check the permissions of the files/folders. Can the users map there share to the local computer?

I can remote in, I can copy a file to the share. It creates the file but doing so it dosn’t move data. so the file is 0kb I can delete files. I can even move files. Its just a problem when I try to create new files.