Help...trying to access files on Mybookworld Blue Rings

Good evening,

Need some help/suggestions.

I have a Mybookworld blue rings that I am trying to access. By either connecting the mybookworld to my home network by connection to my router or the mybookworld via Ethernet cable to my Mac mini, I can see the drive under “shared.”

However, when I select the Public folder I can not see any files even though a quick look of the folder shows I should have about 420GB of data there.

Using Safari, I typed in the website mybookworld.local and the Shared Storage Manager menu comes up. However, when I select a tab, it asks for a name and password which I do not have.

Yesterday while on the phone with WD, we tried to reset the system by unplugging power, pushing in the reset pin and then applying power holding for 4 seconds and then releasing. We then tried the Admin/123456 to login and it did not take that. So really not sure if the device reset or not.

As a test I did drop a file into the public folder and it saved and I was able to open up the file from the device, so I believe it is working.

I just can not access the previously stored data…

Any suggestions at all? I found a data recovery service here in the city but rather not have to drop $350+ to have them get the data…

Appreciate any assistance/recommendations
Scott

Did you try admin/admin or admin / (blank)? You should be able to see your other shares if your can the the main Public share, but they will ask for credentials. Try manually mapping them: