Help setting the WD1002FAEX-007BA0 1000GB hard drive to Sata III instead of Sata II

I have this particular HDD, it’s Sata III according to WD official website. My mobo also supports Sata III, so I don’t know why my PC detects it as Sata II (this according to some programs such as HD Tune and AIDA64 Extreme Edition).

I’ve heard something about some jumpers, though, I don’t know what they do or how can I “set them right”.

But I’ll do it, as I’m not an amateur on the matter. So don’t be afraid to help me, please!


My PC Specs:

   Operating System: Windows 7 Home Premium 64-bit (6.1, Build 7601) Service Pack 1
           Language: Spanish (Regional Setting: Spanish)
System Manufacturer: Gigabyte Technology Co., Ltd.
       System Model: GA-870A-UD3
               BIOS: Award Modular BIOS v6.00PG
          Processor: AMD Phenom™ II X4 965 Processor (4 CPUs), ~3.4GHz
             Memory: 4096MB RAM
Available OS Memory: 4094MB RAM
          Page File: 3480MB used, 6749MB available
        Windows Dir: C:\Windows
    DirectX Version: DirectX 11
DX Setup Parameters: Not found
   User DPI Setting: 120 DPI (125 percent)
 System DPI Setting: 96 DPI (100 percent)
    DWM DPI Scaling: Disabled
     DxDiag Version: 6.01.7601.17514 64bit Unicode

xutnubu, maybe you should try contacting WD’s Technical Support about this. You can do so either by phone or email.

To Contact WD for Technical Support


FWIW, WD provides a utility called WDSSpeed to “enable Serial ATA Gen 3 (6 Gb/s) support on the following models if Gen 3 is currently disabled”.


Thanks for the reply.

Apparently the problem was the free version of HD Tune.

I tried the pro version and the HDD is being recognized as Sata III.