Help! Red light on WD Mycloud....less than a month old!

Here’s my situation.  I bought a WD My Cloud less than a month ago and it worked very vell.  No issues out of the box.  Even updated the firmware with no issues.  Was running well for about a month and then today I get the red light. I tried rebooting the network, along with mycloud and still have the red light.  Also tried resetting the device (both ways in the instruction manual) and that didn’t work. 

I then called customer service and after about a 20 minute wait explained all this to the rep who wanted me to reset the device again (like I hadn’t already) and bad connection or not I swear the guy simply hung up after a few minutes of waiting for the device to boot. Instead of calling wd’s crappy customer service I figured I’d hit up some people on this board because I’ve been helped here in the past a few years ago.

I read through some of the others post on this issue and was wondering if anyone else ran into this problem?  Unlike those people I was unable to access my dashboard. I’ve also never touched linux.  Any help or idea’s would be GREATLY appreciated.

Hello there…

I’m haveing the very same problem but it’s worst for me. 

My girlfriend travel abroad, from Venezuela South America, to USA. She brought me a WD My Cloud 4 TB Model as a gift to my country when she came back. Surprise! since I got it out of the box and connect it, it turned on the red light. I’ve hard reset it, and theres nothing else I can do because in my country there is not WD customer service.

Please Somedoby Help me.

First a couple of questions, have you tried getting to the dashboard by using your IP Address for your WDMC? See example http:// 172.XXX.X.XXX except do not leave any spaces in it as I did to avoid a unusable link. If you can get to it shut down your My Cloud. Follow this Settings>Utilities>Device Maintenance>Shut Down.


Second did you give it a cooling off period, or were you even able to shut it down? If not and you can shut it down as described above then wait for a while before restarting it, give it plenty of time to cool down then reboot it.


If this does not solve the problem come back for more info.


2nd Reply to: guardzero,


Since you have not replied to the first post by me I am going to go ahead and add the other faults listed in the UM for a Red light.


Disk SMART failure, from what I read this means your hard drive inside the My Cloud is about to go out. Click on link below for more on this.


Data volume does not exist


System volume does not exist

Sorry for the late reply. I finally got a chance to get back in front of the computer. So there has been a good development. I did give it a long cooling period (all night) disconnected.  I re-connected it and I now have the blue light. So far everything seems to be back to normal. I appreciate the prompt response with the idea for the long cooling period!  That seems to have just reset it I suppose.

As for getting to the dashboard while I had the red light originally, I did try getting to it strictly using the ip address and no success that way. It seems the cool down period helped and everything is functioning normally now.  Fingers crossed I won’t have any more issues with it. If I do I will post again.