Help needed with WD tv live and twonkey

Hey guys

I have a qnap ts-639 now running firmware 4.1.0. I have a Tv live connected to my home cimema with Ethernet firmware on WD tv also updated. Normally this works great but I am quite sure the problem that I will describe has been there since qnap firmware upgrade.

Since upgrading the qnap the twonkey in the app center is version 7.2.70. on my pc everything seems to be just fine.

Twonkey server is running and sharing from the qmultimedia folder on the Nas. Under sharing in twonkey the WD tv live shows up. All navigation type is set to “advanced media navigation”.

The problem is just that when i turn on the wd tv live and access media server there is no twonkey (only my pc and iphone)

Last night I spend all evening trying to find out what to do. Going through the qnap interface trying different settings. Searching the net for a solution no luck.

I never had problems with the twonkey server not showing up on wd in previous qnap firmwares. I’ve used twonkey 6.039 for a long time. Also tried that version on the new qnap firmware same result.

I hope some of you in the forum can help and I think that I cannot be the only one using qnap-twonkeymedia and wd tv live in combination.

Maybe I am overseeing something in the qnap interface. I am also unsure what to tick under “DLNA mediaserver” on the qnap.

So basically ANY help would be greatly appreciated.

Thanks in advance and sorry for my not so native english.


This seems to be an issue on the side of the media server. I recommend seeking assistance on the Qnap forums. Or maybe other user’s in this forum can share some thoughts on this.