Help needed! MyCloud Mirror disconnected itself, even a ping didn't work

The System disconnected without any reason from the Network.

  • it comes again after the power reset and works for a while, but then get lost again
  • I’ve tried dynamic IP or static -> without any result

any ideas?

best regards and hope for a solution :slightly_smiling:

Hi, what version of the firmware you have on the My Cloud Mirror? How is your computer connecting to the network?

I’m having this same problem. I just bought a Gen 2 and have been “test driving” it to verify it will fit my needs. Unfortunately, one of the problems I’ve run into is a regular loss of network connectivity that seemingly can be corrected only by power cycling the device. I haven’t been able to relate the drop in connectivity to any device or network event. I have a basic Linksys wireless router which is serving 4 wired and 2 wireless devices. The device has been connected directly to my router with a 6-foot cable and none of the other devices lose connectivity, including an old NAS that the Gen 2 is meant to replace.

One of the first things it did when I set it up was upgrade the firmware. I’m not sure what version it picked up (because I can’t get it to boot up right now…which is a problem for another thread) but the latest firmware release on the product download page is dated two days before I bought it. So, I’m assuming it has upgraded to v2.11.133. If it turns out that version is not what’s on my device I’ll try to update it or post the version it’s on now.

I’m facing the same failure for over five weeks. The MyCloud Mirror Gen 2 (MCM) is not visible on the LAN. I’ve tried with four different 1Gbps switches. Always invisible (down light of the LAN connection remains yellow, power light switching in blue twice per second, fan operating and never stopped). The “Factory Reset” switch did not operate despite many careful attempts. I remove it from the LAN and store it in a cupboard to forget it (I was tired of it and of the time spent). One week later I reconnected it to the LAN and switched Power On, it was accessible! The firmware was updated to the last version 2.11.313 but some hours (about 12) later the MCM Gen 2 returned to inaccessibility! I also discovered that in Mac OS X Finder the MCD Gen 2 was declared “PC” when it was becoming inaccessible – not “Mac” as the two others MCM (one EX2 and one MCM Gen 1), then the IMac did not see it. I take the opportunity of having one extra MCM to check the discs (in RAID 1). There were in good state and I could retrieve files and directories. I’ve exhausted all the ideas I’ve to fix the failure.

This reports one extra MCM Gen 2 having LAN connection troubles. I look forward for a fix!

My firmware is 2.11.133. MyCloud is connected by LAN to the router, other 4-5 devices connected by WLAN. the Network runs good, without any problem with other devices/connectivity. what is really strange /curious is that
-the connectivity get lost without any reason, at least without any clear pattern and then suddenly day after come back again without any Action from my side

  • beeing lost, I cannot see the Mycloud system on the lowest connenctivity level -ping test from router!! failed

it’s time for the WD Support Team to come with the solution :slightly_smiling:

The community cannot assist if you’re only posting “my car makes a noise” REALLY ?? LOL!!!

What switch?
What router?
OEM ethernet cable or self provided?
Any 3rd party apps installed?
What were you doing when it disconnected?
Post up some system logs so that the board can help?

BTW: I have My Cloud, Mirror Gen1 & Gen, EX2, DL2100 and DX2100 and I have zero issues.

To jeepnsam

“The community cannot assist if you’re only posting “my car makes a noise” REALLY ?? LOL!!!”
We gather the statement don’t expect any help from the community.

I’m facing the same problem and I’ve three extra NAS EX2 and WDMCM opertaing with “zero issues”. They are connected to the same switch (a D-Link), the router (NetGear WNDR 4500) assigns each a permanent IP address. No 3rd party applications installed.

Moreover two years ago several reports of this trouble have been posted.

How one can provide a report from the NAS when it is not accessible from the LAN? This is a useless request for not saying a stupid request.

No one can understand what is happening. The system can be accessible to the LAN for 24 hours or for 5 minutes only. Simple operations : move or retrieve or display pdf/jpeg files to the MCMGen2, remote backup to another WD NAS. No other types of access.

Even when a dedicated test LAN without firewall is built the MCMGen2 exhibits the same failures : becomes invisible and inaccessible without notice and even without doing something. Disconnected to the LAN and to the power supply and then reconnected the power light flashes twice per second, and the down Ethernet LAN flashes in yellow instead green (and don’t tell me it is a 100Bps Ethernet LAN, it is a 1Gbps.

No one should appreciate your answer. I’m however grateful to you for showing that this WD Community is quite useless unless one needs to relax a little in describing the troubles one is facing, but don’t expect any advice or information.

The system can be accessible to the LAN for 24 hours or for 5 minutes only.

5 minutes to 24 hours is long enough to:

  • obtain and read the system logs (post once you get them)
  • change from DHCP to static
  • change link speed from auto to 100 or 1000
  • etc…

To jeepnsam

Do I need not such advises when having so many years experienced in designing, building and managing LAN and WAN? (1) DHCP without reserved IP address (MAC Address), DHCP without IP reserved address, Static Address – same result. (2) Each time the WD MCMGen2 is working the first things I use to read are posts from the router and posts from the MVCMGen2. (3) Changing the LAN Speed when connected to a 1Gbps switch? and furthermore stated as a 1Gbps by WD? If so there is a failure in WD advertisement the LAN speed in 100Mbps and not 1Gbps. Could I believe it? (4) I run also the system and disk tests at the very beginning, both return good status for every feature tested (each one is declared v). (5) There is not disk failure as when inserted in an other WD system they work perfectly.

The posts are poor. The sole strange message is “Power Loss detected on Port 1”. No documentation available about the meaning of this message. The other ones are the same ones as the other WD NAS display
; they never display this message even if a power failure happens. They operate without trouble.

The failure is - presumably (my hypothesis) - not a LAN failure but an “initialization” failure. At connection time to power supply, the MCMGen2 software program loops (reason unknown) and does not reach the point when the LAN connection is established. This is only an hypothesis as there is no means to debug the initialization software or to view its operations step by step. Once the network connection is established the MCMGen2 is accessible, may be not for long but it is. There is another trouble: the “Factory Reset” does not work in such situation (no LAN connection) whatever the care to execute it (User Manual, or as explained in a post). If the LAN connection is established the “Factory Reset” works. I would add when the “Factory Reset” has worked the MCMGen2 works for about 24 hours and quite well (e.g. switch off/on for a few hours, remote backups on another WD NAS, etc.). If the “Factory Reset” is not run the MCMGen2 fails after 5 minutes.

Another strange observation. Under Mac OSX Finder (Yosemite and El Capitan) all WD MyCloud are displayed as of type “Mac” (after all they are Linux systems). When the MCMGen2 looses its connection the displayed type becomes “PC” (but not accessible) for a short while (two or three minutes at most) and then the whole mention disappears.

Note that the troubles (invisible and inaccessible, not the type, that is peculiar to Mac OSX) are also observed from a PC under Windows 7, from NetGear Genie, from NetGear router posts, from PC with Windows XP, from VMWare Vision Virtual Machine Windows XP.

to all skilful professionals

happy to see you are here :slightly_smiling:
the problem is my limited skills in network administration and (to be honest) no desire to improve this. finally, I do not have any desire to be professional in TV, car, house, mobile, power and bicycle engineering. What I want is to buy a product and to use it! not more, but no less.

I have tried everything what I can - static IP, another cable, another port on my router, ping from another device, ping from the router itself - without any positive result. At he moment (!!!) I have the connectivity with the system, tomorrow - may be. IMHO - the problem is with the connectivity on the very low network level - so far my limited skills allow me to judge.

I hope another cases, users, product owners, bringing their experiences and skills and observations together can empower the WD to solve the problem finally. Happy to know that I’m not alone with the problem :slightly_smiling:

Same problem here. (MCMGen2 8Tb) For some weeks drive ceases to respond. Can’t access from anywhere.
I reboot, wait for the 3 blue lights to become still and then I can access it for a couple of minutes, before it becomes unresponsive again. It does remain operating thought.
I have two apps installed: Dropbox, Plex

Below Latest logs received (by email). Any idea on what to do?

Event title:Media Scan Stopped
Event description:The device stopped scanning your media. As a result, some thumbnails will not display when you access them remotely. To resume scanning, please restart your WD My Cloud system.
Severity:Info
Event code:2300
Event time:02-18-2016 01:21:36 PM
Firmware version: 2.11.133

Event title:Power loss detected
Event description:Power loss detected on port 1.
Severity:warning
Event code:1022
Event time:02-22-2016 08:24:09 AM
Firmware version: 2.11.133

Event title:Media Scan Stopped
Event description:The device stopped scanning your media. As a result, some thumbnails will not display when you access them remotely. To resume scanning, please restart your WD My Cloud system.
Severity:Info
Event code:2300
Event time:02-18-2016 01:21:36 PM
Firmware version: 2.11.133

Same Problem here and already tries alot of ways to fix it except opening up the unit since it will ruin the warranty (although I doubt WD warranty service will do any good to this kind of problem)
it has been 3 week from the day,I bought it and I think I start to lost of my confidence to all NAS WD product and will change our standard for NAS to other brand product.

Did anyone get a satisfactory answer to this problem? My Gen 1 started exhibiting the same symptoms (dropping off the LAN at irregular but frequent intervals and only reappearing after a power-down/power-up) a couple of months ago. No relevant log entries, very latest firmware, connected to router/modem via ethernet cable, same on two different routers, different cables, static and dynamic IP etc. Makes the thing effectively unusable as it often drops while copying to or from. Diagnostics reports no problems.

Frustrated & disappointed!