HELP: MyBookWorld II unresponsive after FW update


#1

Hello, after upgrading firmware, the drive have become unresponsive and doesnt show on my network. the LED light is stuck on the lowest capacity setting, and resetting or cycling the power doesn’t change the light or start the boot up sequence.

i followed the firmware instructions precisely, and after it said it was 100% complete it never rebooted fully. please give me options to resolve the issue, thank you.

Hello, after trying to update to the latest firmware, the drive have become unresponsive and doesnt show up on my network under any name. the LED light is stuck on the lowest capacity setting, and resetting or cycling the power doesn’t change the light or start the boot up sequence.

i followed the firmware instructions precisely, and after it said it was 100% complete it lost connection and never rebooted fully. what are my options? is there a harder reset possible (without losing data?), any help would be GREATLY appreciated, thank you.


#2

When you say resetting, do you mean the reset button or just power cycling ?


#3

by resetting i meant both power cycling and holding the reset button for 10 seconds.

apparently, the firmware update was STILL applying itself long after the 30 minutes the warning said it could take “up to”. after leaving it alone for an entire night, the drive was alive and working with the new update applied.

to apply itself after all the resetting and power cycling i did is a testament to how robust the design of the firmware update process is.


#4

I have done the same but waited a week and still nothing!  any ideas?


#5

Wich firmware ?


#6

I do not think the issue is the firmware  although I am in the same position with the latest firmware.

I upgraded the firware and I do not think it correctly installed and has corrupted the system.

Hence the white light at the lowest point and nothing connected.

I too have power cycled and even tried the reset (which will only  reset the password and network so no help really).

Mybook device white light  is also at the lowest setting and the discovery software does not show the mybook device or dirves,.

I have just  opened a ticket with support on how to roll back to the last good state.

I will update if they provide me with the answer, I am not feeling too hopeful at the moment.


#7

that would be great thanks!

cheers


#8

I did the same regarding the support ticket. See my other thread if you need to get your files off it: http://community.wdc.com/t5/My-Book-World-Edition/Firmware-update-gt-Unit-unresponsive/td-p/45564

For now we wait,


#9

Exactly the same “unresponsive” behaviour happened to me with my 2Tb whitelight (as mentioned in the 1.02.04 thread). Lowest light bar remains lit, disk seems to be spinning (making the right noises) but no net visibility or way to access through my router.

I don’t have a linux (or flavour) installation and don’t need the data since I have multiple copies. I would however like a way to bring the unit back to life so I could use it as intended. Some kind of super-reset or button combination to force a real hard-reset (reload kernel from an internal ROM?) rather than just reseting the net address/password.

One thing I did notice (if it helps anyone) is that with the net cable plugged in, on the green LED (by the plug) was lit, the orange was not flashing or anything. It’s as if the net doesn’t even want to try and handshake …

Best,

Gary.


#10

From reading around and looking at the drive contents in linux, the OS for the unit is stored on the same data drives… probobly because its cheaper to make it this way. The problem is if the OS os nuked like in our case then there isn’t a magic restore button as there is no rom to get it back from.

The only way to being this back (unless some WD rep steps in here and convinces me otherwise) is to restore the original image of the drives which can’t be done with the tools we have available to us.


#11

MDKv4, you are correct.  The only way to restore the drives is by replacing the whole unit.  You could RMA it as long as the drive is still under warranty.


#12

Yes understand and my drive is still under warranty but what about all my data?


#13

Hi all,

I think I have the same problem but I didin’t update the firmware. I tried to enter the network storage manager but I had no access with my password. so I read in the manual about resetting the password.

I pressed the reset button but nothing happened. I waited 30min and tried to turn it off by the power putton. The same nothing happend.

Now I have to get a RMA and send it back. But what happen to the data on my drive?

Bye

Horith


#14

You will lose all your data.


#15

I’m in the same boat! I decided to update the firmware for the drive this morning (hadn’t been updated in over a year and figured it couldn’t hurt) and the update completed correctly but the drive never came back onto the network. Lowest LED is on and occationally goes off and then back on. No network activity light but there is a connection light (green). I’ve read some here and think I may be hosed. I sent an email to WD Support but I don’t hold out any hope.

Unsure if the drive is under warrenty but even if it isn’t if their Firmware is crippling the device they should cover the repair (and data recovery if needed).

I’m really not thrilled about this and hope that it will get resolved…Anyone out there have any success?


#16

UPDATE: After spending some time on the phone with support they have determined that the drive is no longer functional and that I can get an RMA to have it replaced.

Data recovery is up to me as they don’t cover those services…nor can my pocketbook as a student afford it. So I am forced to either loose all my data (really not acceptiable) or I need to pay out the nose to recover it. I assume that by attempting to recover data off the drive by opening the case will void the warrenty makng RMA no longer an option.

Frustrated to say the least…


#17

Hi.

I have the same kind of issue. My HD is a MY BOOK WORLD EDITION 1tb. The light is on all the way up but it keeps a steady blinking, but I cannot access it. When I use the WD Discovery it says that the HD is not connected or on. Do you think the HD is bad? Any help, please?

Thank you.


#18

Hard to say, if you upgrade to firmware 1.02.04 the problem is definitly new firmware.


#19

Hello,

I did exaclty as MDKv4 suggested in this thread:

http://community.wdc.com/t5/My-Book-World-Edition/Firmware-update-gt-Unit-unresponsive/td-p/45564

After I got partitions to show in Ubuntu I went to Upgrade folder and renamed both upgrade1.sh and the new firmware image file. I had RAID0 configuration so I did it to the both disks separately to make sure. You have to do the renaming trough the terminal session as root since they are protected files.

After that I just put the disks back to the case (take care to put them to the same slots, otherwise the ride might break) and it booted up nicely. And the first thing I did to the working nas…I took a backup :smiley: I’ll never trust that box again…

Hope this helps some of you.


#20

Same problem here. Pushed the “Upgrade” button yesterday and the unit is now blocked at the lower white led, lots of disk activity, green light only on the network interface.

I think WD just bricked my unit.