HELP: My Passport Ultra no longer shows up in my computer and Disk 1 is not initialized!

I purchased this hard drive a few weeks ago. I initially plugged it into a USB port and installed it correctly. Everything was working fine as I transferred a couple of small files to the drive. Something happened and everything froze on my computer, so I restarted my computer and the hard drive has not shown up in My Computer since! I am not worried about losing any files from this drive (since I only transported a few and this happened during the FIRST time using the drive) so I will do anything to get this hard drive to work. When I open Disk Management it shows up as “Disk One: Not Initialized.” There is no black bar to the right displaying that it is “unallocated” or what not. 

Then when I right click on the Disk 1 box in attempt to initialize the disk, this pops up.

I’ve been trying to work this out for days upon days. I wouldn’t be as bothered if I couldn’t fix it if it never worked, but it worked perfectly fine the first (and only) time I used it. Also, when I type “list disk” after accessing command prompt, Disk 1 is listed and the status says online but it says that the size is 0 GB and that there is 0 GB free (keep in mind that this is a 2 TB drive). There are so many forums similar to this one but I couldn’t seem to find any results. PLEASE, PLEASE help me.

Hi lisamarieee, try using another USB cable, if the problem continues, the Passport would appear to be faulty and needs to be replaced. You can contact support to replace it, or create the RMA online.

How to get an RMA, (Return Merchandise Authorization) or replace a defective product under warranty