Help! My Passport Ultra 1TB not showing in This PC; not formating from WD drive Utilities

Hello Community,

I have a My Passport Utra 1TB drive I have been using for 6 months now. Five days ago, I was deleting some files from it and the process seemed to hang. Them I heard the sound of a usb device disconnecting. From then on my device didn’t appear in This PC again ( I use win 10). I tried everything from restarting my laptop to uninstalling the device driver to updating the hard drive firmware. Nothing worked. It shows in my devices and printers; It shows in device manager; It also shows in disk management but is unable to initialize and is not even showing properly in in disk management, It shows as a drive with the whole 931.45GB unallocated. I can’t create a new volume, I can’t delete volume on old versions of windows. I can’t erase drive from WD drive utilities. I tried to use GetDataBack and EaseUS to retrieve my data, the two applications ran deep scans for several hours after bringing up countless errors only to say 0 files found. What do I do please?? Can my hard drive go back to being normal again? Or will I have to format it? If I have to format it, how please?? Can I still retrieve my data?
Please help!!!

It seems like your drive is lock with a password (encrypted). You can download WD Security application to see if it recognize your drive. If it can see your drive then it will ask you for the password that you or someone might have set. Because of your statement “it also shows in disk management but is unable to initialize” That indicate the drive is lock with a password. That is why none of the data retriever can scan your hard drive.

Hi. It’s not encrypted. I checked with WD security app. It is not.

Time to call WD support hotline.

Did you succeed ? I have a similar problem