Help! My passport cannot be recognized on PC, tried everything I can

All of a sudden, my passport 1TB cannot be recognized on PC. I tried different PC, both laptop and desk computer, both WIN7 and mac, also changed a cable, not working. I have all of my photos over these years in it, I hate that I didn’t have them backup again!!

At first, my WIN7 recognized 2 of all 5 partitions, and for the other 3, it said “need format before use”. Then I unplug my passport and plug it in again, only heard the  “beep” and the light on my passport is on, and it sound working. But I cannot find it under “my computer”.

I download the driver from WD and install it:

http://wdc.custhelp.com/app/answers/detail/a_id/5419/session/L2F2LzEvdGltZS8xNDE1MzA1MDE0L3NpZC9wTUVlb002bQ%3D%3D

and I can see the following in “device management”:

device-management.PNG

usb-new.png

When I clicked “Open devices and Printers”, I can see my passport:

device.PNG

Finally, I download the WD Data LifeGuard Diagnostics, and it showed my passport is not available, sometimes it even didn’t show on the list. I failed to run a quick test on it, as it seems not taking any progress for a very long time or now it just didn’t show up in the list so I cannot run the test.

Diag.PNG

I searched on the forum, saw many people had the similar problem, but not exactly the same. I hope someone can help me to get my data, all of my photos, sign…

Welcome to the Community.

Maybe you should try contacting WD’s Technical Support about this. You can do so either by phone or email.

To Contact WD for Technical Support
http://support.wdc.com/contact/index.asp?lang=en

Support by Country
http://support.wdc.com/country/index.asp

Regards,

1 Like

OMG! I’m having the same problem too! It just happened less than half an hour ago. I have no idea what to do. Did you solve yours yet?