HELP: My Passport 1TB issue


I have a moderately new WD Portable Hard Drive and all has been well until recently. 

While using my portable drive one day, I was alerted with the prompt that informed me that I had to format the drive before I could use it - as I didn’t want to lose my files I immediately hit cancel. Under the impression that it was a one off, I let it go. Several minutes later I was bombarded with the same prompt every minute or so. As a result, I unplugged the portable drive and went ahead to try and find some solutions to my problem. 

I found a recovery program (Recuva) thinking that after I format the portable drive, I could recover the files. As I proceeded to format the drive, I was informed that the drive could not be formatted. I also tried to recover the partition of the drive (not sure what it is but I read about it and hoped it would solve my problem). With no luck with those procedures I discovered that my passport was not appearing in my computer. 

Could anyone please provide some insight to what I should do?

Please note, I have already tried other computers or USB ports, the same happens. Also, the drive tends to slow the computer down when plugged in. I have also connected the portable drive to my TV and it has worked fine. I looked around the drive and everything was there (as expected as I didn’t format it). However, still no luck on accessing the drive on the computer.

Hi, to recover my files I had better luck with testdisk, check below for the download link.

I am unable to use any recovery programs as the drive does not connect to my computer.