HELP! My Book Elite 1TB isn't even noticed by Windows!

Ok, so here’s the problem, my My Book Elite isn’t noticed by Windows at all anymore! I’ve looked everywhere, the light on the hdd is flashing to indicate that it is working, but the gauge to show how full it is does not appear, only the name of the drive, and the light.

I’ve already looked in computer management to check if it has a drive name, but it’s not even listed.

I have installed WD SmartWare and it isn’t listed there either.

I tried using the My Book Firmware Updater, but it keeps telling me that I don’t have a My Book device connected.

I’ve tried updating the device driver software, but I can’t find any software to update.

It’s not recognized at all by anything on windows!

I’ve tried switching the power supply and data cables with ones that I know work.

I’ve tried looking under Device Management in hidden and disconnected devices and I can’t even find any references to it.

This started when I re-installed Windows (went from 32-bit vista to 64-bit vista (big change, I know)).

Can someone please help me because I have files on it that would be incredibly difficult (if not impossible) to find again!?

The only thing that you have not tried is another computer

if that does not work… you will need to contact a data recovery company

1 Like

does your drive make any clicking sounds? cuz if it does thats your problem right there.


Just tried a computer, my laptop, nothin there either.

Might I be able to get a new one since the warranty is still valid?


It just makes the sounds you would expect when it’s trying to spin up, why? Is that a problem?

if the drive make constant clicking sounds and then spins down, then chances are your heads in the drive are dead.

do you have another usb enclosure? you can try to mount the drive via another enclosure; however, your product is hardware encrypted and wont show any files if hooked up to regular USB adapter. but it would help to see if the problem is with actual drive or your current enclosure. if drive mounts - replace the enclosure with identical one (there would be part numbers on the USB controller). if drive doesnt mount in another USB enclosure then your drive may need data recovery ppl to have a look at it.

if this post is useful click on Kudos for me :slight_smile: thanks

If you open the drive you void the warranty.


1 Like