HELP! “My Book 3.0” doesn’t work with usb 3.0 but works with usb 2.0


i just bought the “my book 3.0”, connected to PCI-E usb 3.0 card, and tried to run the device without success…

the My Book works pretty well with the usb 2.0 connection, but does not respond when connected to the usb 3.0 port.

i checked other devices, and they work well with the usb 3.0 ports, so there isn’t any problem with the port itself…

i didn’t find any answer, and i would be thankful for your help!

Thank you!

Blank Post?
Please see here: IE9 and WDC Forum Compatibility

thanks :slight_smile:

What OS are you using? Did the PCIE card come with the WD drive? Is this a new computer that came with USB 3.0? There are issues with PC’s built before USB 3.0 was introduced and some cards. Are all of your drivers and BIOS up to date?


I’m using Windows 7 64 bit. this is the card that came with the “My Book”, yes.

The computer is one year old, and doesn’t have usb 3.0 built-in, but i tested the My Book on another brand new computer with usb 3.0 buit-in and it worked fine…

My driver and bios are all up to date.

Thanks for your help!


If you can identify the card maker look on their site they may have a different driver. I can’t think of anything else.