Help ! MacBook does not see new drive

Please help. I bought a brand new My Passport 2TB portable USB drive for my macbook Air, running Mavericks. As I prefer not to use WD software I immediately formatted the drive for Mac, the way I always do (I have 3 Passports). I uploaded succesfully about 100 large files. So far all good. I name the drive ‘Silver Drive’.

I unplugged and half an hour later wanted to add new files. The little light on the USB drive blinked on connection, then was on permanently but i saw no icon in Finder. Went to disk Utility and did a disk verify and disk repair, and there it was but it only showed ‘Silver Drive’, not the usual orange icon of WD. Thios was still in disk Utility as the drive is still invisbile in Finder. I tried to mount the disk from there and it asks me for a password. I remember the password very well as I haf just typed it in 30 minutes before. yet, the computer will not accept the password, the dialogue box just starts shaking.

What is wrong here? Why do I not see the drive in Finder and why will it not accept the passowrd I am 100% sure of I used ? Hope I did not loose the 100 files…

Hi KiwiOz, have you tried using another USB cable or another USB port to connect the Passport? Be sure to connect the Passport directly to the Mac, longer cables or USB hubs can cause power inconsistencies. 

Sure, did all that. No success. i think it is just dead and requested a replacement as it happened within the first few hours, right out of the box.

First WD drive to fail me.

same here.

i cannot mount the 2 TB mypassport anymore under 10.9 mavericks.

2 weeks ago, i mounted it, it was fine. i tried 2 different macs and 6 different usb ports

is there a bug in 10.9 which collides with the WD driver?

is it damaged?

my topic:


Is this a Mac problem? Maveric seems to be causing problems with the external RAID drives. I wonder if this more of the same.


Have you tried deleting the WD drivers disconnect the drive and rebooting system? After reboot connect the drive again.


no thanks, i will try, but i dont know where i can find the wd drivers in osx 10.9,

is there an official doc. by wd?

i tried connecting my other 3 wd passports from 2010, 2011 and 2012 and they connect and mount well!

so its not caused by system 10.9