Help identifying encryption features, device not showing in WD Utilities

Hello guys. I recently came into a drive, specifically

My Passport 0730 1TB USB 3.0 external HDD

It says in the manuals online and in a lot of other places that this drive supports hardware encryption and password locking, but when I run the WD Security software it just sits there saying No Drives Attached “Please attach a supported WD drive”

I am using the USB 3.0 cable that came with it, and it’s connected to a USB 2.0 port.

Did I miss something here? When I run the WD Utilities, it does the same thing, saying please connect, like it doesn’t recognize the drive.

When initially receiving the drive, I did a full long-format. It works just fine, and windows explorer can see it fine, and it’s got 800gb loaded on so far. I was hoping to use the WD official features to manage this hardware encryption, but I’m worried that it may not actually have that feature and I may just have to use Bitlocker. Any ideas guys?

Thanks for reading


WD Security and WD Drive Utilities are not compatible with the listed model (WDBACX0010BBK-00) as they were designed for a more recent generation of WD products.

In order to trigger and/or manage encryption for this model, WD SmartWare must be installed in the host system as it is application designed to manage the features of this unit.

1 Like

Thanks for your help. IDK what happened to my previous account, but I cannot access it or reset it’s password, some kind of site bug. 

This is what happened after I enabled the password and ran the DLGDiag program on the hddd…

Everything was going fine until… Where does this leave me now?


Do you obtain the same results if you disable encryption? Some sectors may not be accessible for testing with an active password.

If disabling encryption does not allow for the disk to pass the test, then it would be best to replace it under warranty for free. Additional instructions are available in the following link: