Help... Hub powers up... WD light flashes... then

My first post, hope this helps…
Power switch mystery solved, (At least on my unit). Sorry if this gets technical.
I’ve had my Live hub for just over a month and last night I joined the re-booting club!
Like others here it got to the “loading” stage and then shut down.

I bookmarked this forum while researching before purchase, but missed this issue.
Many thanks to those here who have already done the hard work of pointing to the problem area.
I bought mine via eBay, new and sealed but may have been a private seller so little comeback. (UK)
Having read of the slow response to replacements, plus over a weeks work loading and setting up
the player it did not want to loose all that; so decided to take matters into my own hands.

Now retired, I have worked as an engineer in electronics for the past thirty years and have had
to diagnose & cure similar “production issues” in the past, so tackling this was not very daunting.
As has been said, disconnecting the power button PCB stops the problem but now why…

The switch circuit is very simple, a 4-pin connector -2 pins are ground (groundplane on PCB), the next
pin is the logic switching signal and the fourth is +V supply (probably 5 or 12V but didn’t measure this).
The supply line has a 0.1uf decoupling  capacitor followed by a 4K7 resistor, this is the pull-up to logic
high for the switch. The momentary switch shorts to ground providing the “low” start or shut-down signal.
This switch looks a little fragile for the weight of the average thumb pressing on it, plus the tactile feedback from
the click is very poor; leading to the temptation to press even harder. But that’s another story.

My first action was to check the switch resistance, ok shorted to ground fine, but when it was supposed to
be open it measured about 160 ohms across the contacts, well within the “low” state, so permanently “on”.
I suspected cheap & nasty switch (which it is!) but to my surprise it was OK. Very little else to cause this reading
of 160 ohms, I studied the PCB under a microscope and could not trace or see any shorts.
Finally came to the connector, the four pins on the underside of the board had flux residue between the pins
This proved quite stubborn to remove even with correct cleaner, but once clean the low resistance had gone!
No sign of poor solder joints anywhere. I’ve come across this before with surface-mount pins where solder paste
gets into the flux which then sets to a thick paste containing a partially conductive medium. Not good news!
The answer: CLEAN THE PCB’s BETTER. (Bring back good old solvent cleaners)

I had to replace the switch so fitted a more robust component (with a little difficulty). All reassembled a running
again. This was diagnosed & fixed in an afternoon, surely WD have the recourses to do this, really shameful
given how many complaints are on here and how long this has been going on. Probably all about cost!
Not all with this symptom may have this fault but as set flux can change with temperature this may explain why it
takes a while in a warm enclosure for this problem to arise, plus the flexing caused by switch operation.

I checked the 12v 2A psu on a load of 2A and it only dropped to 11.9v so that should not cause a problem.

I realise few here may have the skills & tools (or desire) to do this work, so I guess you’re stuck with RMA route.
Hopefully WD will take note of my findings and change their production practice, -we live in hope?

One off-topic question: Has anyone taken the HDD out and read it on a PC?, I think it’s NTFS format.
Just in case I get a more disastrous failure. Of course I do have backups, not safe to store all your eggs in a
terabyte basket!

Sorry for the long post but I hope it has been of interest and perhaps WD will rectify this soon.
Good luck, David


Good work for fixing the problem. Base on your solution, I think people can see now that WD’s only solution for this problem is replacing the unit which is what they are doing right now as WD can’t just send new PCB to replace it ourselves.

On your off-topic question, I plugged mine in the PC. It has two partition and yes it is NTFS, both partition. I even tried to disk check both partition and the result of the partition which contains the configuration files and not seen through the hub indicates some kind of error that I don’t remember as I did that months ago.

Hi Pixman,

I’m assuming our engineers found the same thing when they fixed it.  But we’ll pass this along just in case.

GREAT job!

Would it be possible to post a list of parts and number and where they were purchased? I’m thinking there are others of us who may not be able to diagnose a problem like this but have the skill to make the repair. It would be a great help to us all as it already has!

I wanted to post something additionally.  If you need a replacement and you are going to RMA.  If you contact support, and request to open your product to recover data, if approved, they will be able to create an RMA so that the warranty will not be voided from opening the device.

Just to answer a few points:

Thanks to b0y0ng99 for the disk info also to Toretto, it’s good to know we can retrieve our data (provided the disk hasn’t died of course).

Flhthemi, there aren’t really any parts to list. I had to replace the switch as removing a surface-mount component with one iron usually damages the part and I only did this as it seemed the obvious candidate for the problem. As it turned out I needn’t have removed it.

I would not recommend changing the switch (as I’m sure WD would agree), as I had to replace it, I just picked the best option out of my used spares box (several hundred switches!) -& it was not simple to fit.

Unplug & remove the switch PCB from the box and inspect the 4 pins with an eyeglass.

If there is residue between them give them a scrub with a toothbrush dipped in mentholated spirits if you don’t have de-fluxing solvent.

Do NOT use a metallic tool as it could damage the PCB foils, (wooden cocktail stick if you need more poke is good) & keep switch dry!

Don’t try to clean while still inside the box some fluids may attack plastics.

If you have a multimeter or circuit tester, with switch not pressed, pin3 (logic signal) to 2+1(Gnd.)  obviously should read open-circuit.

Between pin 3 & 4(+V) should read about 4700 ohms.

Not really directed at you personally Flhthemi, just more info for anyone wanting to try this. Have fun.

Hi Pixman

Can you help me. I’m not too good on all things technical and struggle with the basics. My question - how do I open the unit??? I can’t see any screws. Do I just have to pry it apart?

Many thanks


Hi Paul,

Sorry for delay but only just seen email prompt!

If you are not technical I wonder if you should be trying to get the lid off??

I assume you have this identical problem mentioned, that a fair number on here seem to be getting.  

The removal was described on a previous thread  (sorry can’t remember where exactly) but I know it wasn’t as simple as it was described. Mine was quite stubborn. Above the shiny plastic skirt there is a almost invisible seem, you have to GENTLY prise this gap apart starting at the back and working around to sides to the front. There are a number (maybe 12) plastic tabs which extend down inside. Use a thin wide blade such as putty knife NOT a screwdriver unless you want to damage your plastics. As you work around the lid you will feel  the tabs, these have to be pushed in SLIGHTLY  to release the lid as you go. It is a fiddle and probably deliberately designed to discourage people from getting inside.

That’s the best I can describe it, hope that helps and sorry if this was too late and you now have shattered plastic.

Regards, David 

Thanks David. It’s not too late - haven’t touched it yet! I have a couple of people working with me who are very technical who should be able to find their way around and underneath it so thinking of handing over all responsibility to them.

I’m pretty sure it’s the same problem but still nervous about opening it up. As per others I only bought it a week ago, it worked for the first couple of days and now when I switch it on it powers up and after about ten seconds the WD light on the front starts flashing and it shuts down.

There are so many threads on this topic on this forum that its difficult to see if there’s an official response from WD but I presume there isn’t. A friend of mine actually bought mine abroad where he was working and copied over a load of movies for me so the option of bringing it back to the shop isn’t really on.

Either way it would appear that this particular solution seems to be working but just to clarify it one more time…once I have the top off I am looking to disconnect the on/off button on the front left of the unit. Once that’s disconnected it should work fine.

Is that correct?

Thanks again,


There is only one specific thread that refers thoroughly on this problem and that has almost the same title as this one so if you read that, you’ll find the answers there. This thread is becoming a repeat of that thread so to help you summarize that thread, these are the two options you can do to resolve this problem.

  1. Do WD’s official solution which is is to RMA your device and that is posted here

  2. If you don’t want to RMA, do the remedy that I’m suggesting which is to disconnect the cable between the mainboard and power switch and that is posted here  The only side effect of my remedy is you can’t use the hub’s power switch but that won’t be a problem because you have the remote to do everything.

OK Paul, glad you have assistance & I wasn’t too late. 

b0y0ng99 has saved me the typing so thanks to him. 

I should mention I only started this thread because the original thread to which you refer seemed dead and wouldn’t let me post a reply. I would have preferred the info to have gone there but being new here, I was having problems as it didn’t seem Opera browser freindly (this new version seems OK) the previous would not accept my typing??  -I had to install Firefox to do the post, so was getting a little p***ed off with it all by then! 

Thanks anyway for the interest, didn’t mean to start a duplicate -honest! 

Thanks for your excellent posting, I think anybody that has this problem and can’t get their Hub RMA’ed will appeciate your work. My Hub went dead yesterday and I found the original thread about the faulty switch. I bought my Hub in another country (it wasn’t available where I live), so I decided to try this fix as I couldn’t go the RMA route. As others have reported disconnecting the plug to the switch PCB brought my Hub back to life! It has been working since yesterday with the switch disconnected. I’ve spent the last day reading through the old posts and found that I couldn’t post a new message to that thread either. I have just found this thread you posted and I have cleaned the PCB with a cocktail stick as you suggested. The Hub is now working with the switch connected! I can even switch the Hub off with the power switch, which I couldn’t before! Thanks a lot!

In answer to your question about the internal disk, before I put the Hub back together I removed the hard disk and hooked it to up my PC. As was already posted, the Hub 1 Tb disk is formatted with two NTFS partitions, a 1 Gb private partition and the other main partition, so you can copy data off easily.

As I have an old WD Passport 250 Gb external disk laying around, I thought I would try swapping the 1Tb disk for the 250 Gb one. The hub booted with it’s cleaned power switch and 250Gb disk. The Hub gave me a warning message that the new disk would be formatted. The Hub is now working with the smaller disk and I have put the 1Tb disk in the Passport case, so I now have an external 1Tb disk, as well as a working Hub! I have to wait for the Media library to be re-compiled onto the new disk. As I have all of my media stored on a NAS, I don’t need a 1 Tb internal disk. The 250 Gb should be enough for the media library and any temporary files, plus temporary data storage.

Definitely not something you should try if you still have a valid warranty. In my situation the faulty switch actually gave me a chance to improve my Hub! I now have a working Hub with a power switch that works and a new external 1 TB drive!

Thanks again David and the original poster that diagnosed the power switch problem.

Bill, have WD engineers isolated the power switch problem to any particular batch numbers or production dates? I am actually thinking of buying another Hub, but I would like to know which units might still be affected by this particular problem and if Hubs produced recently have better quality switches and PCBs.

Thanks for your help.

Thanks badmem for you kind comments and glad this saved another from the problem.

I’m just amased how long it’s taken WD to fix this, and even now they seem very cagey to admit to the cause of the fault.

I know sometimes non-surface-mount components such as pinned connectors are mouted & soldered by hand after auto production has been done, so may be we have a human to blame. In any event this should have been spotted by closer inspection. These type of domestic products are always costed to the bare minimum for production -Tiawan I think it was for this box.  It must have cost WD a fortune in RMAs not to mention customer agro.

Thanks for the info on the HDD, I’ll remember that if I get desperate but I don’t have any other 2.5" SATA drives anyway. 

Hi folks, Firstly thank you to pixman for your wonderful diagnosis.

Just thought I’d also chime in to say that my WDTV live hub failed in the same mannor - an australian batch also.

After 3 months operation the unit (running latest firmware) failed and the problem was solved by removing the power switch PCB and replacing as per pixman’s post.

For those of you without proper equipment the problem is easily solved by simply unclipping the white jack leading from the front side on/off button PCB to the main board. 

The clips holding the unit case come apart without much force and will not leave marks should you need to return the unit.

Well done pixman, I wonder if you’ll get an invitation out of retirement from WD!



Just chipping in with a unit bought from the Netherlands. Same problem starting up…it would load up until the ‘loading’ message and would shut off. I thought it was my cheap powerline adapter but luckily this board seems a little bit more alive nowadays. Read the remedy here, opened it up removing the top lid with a small flat screwdriver and some nailpulling, disconnected the powerswitch connector and it loads up again. Cheers!!

this is my second hub, and I wanted to manually update, because I have a lot of videos of 36 Mbps, which not reproduced the earlier version # 02.03.24,with that came the beginning.

 but when i put the version # 2.04.13, after reboting this Happen:

this media player was modified aftermarket and is running unofficial firmaware that is not supported by wester digital.

Now I wonder, I can do, there must be a solution, I download the file from here:  

sorry for my bad english, if someone speaks Spanish and can help will appreciate it.


Well having read another thread that you wrote.

You are not updating the Firmware, you are updating the GPL code.

You need to use the Firmware

EXTRA TIP: picking with a toothpick between the soldering points at the bottom side of the buttonPCB did the job for me. This means: absolutely no damaging the buttonPCB


BTW: Many thanks for posting solutions guy’s & girls!!!