Help... Hub powers up... WD light flashes... then powers itself off. :-(

Do you have a BestBuy locally?   Even if you bought it online, you can return or exchange it at the store.

You’re considering returning it anyway, right?   What harm is there in returning a DEAD one versus one you never tried?

In other words, you don’t have anything to lose.

BobbyL wrote:

I purchased a unit from BB just before Xmas, but have yet to open unit,  I have until the end of January to return it, and have been reading the threads here, especially this one with great interest.  I think I am getting cold feet because I really do not want to go through the hassle of RMA’ing unit if this problem were to turn up in my unit or perhaps a WD recall…


I really would like to have a sense if this power button issue is widespread, that is a latent defect in all units, or just an isolated failure mode common to only a batch  or run of units. 


Anyone want to chime in with a recommendation as to whether to return unit or give it a try knowing the problems others have had?


Thanks for your thoughts on this.

If you read any of the threads you will see that most of the forum do not have this problem and that includes me. You can’t live your life with what might happen. If you really don’t want it then take it back but if not then just open the box and start using it. This is a forum where people come with their problems and therefore reading the posts can be depressing but this a minority of the total users. If it is faulty then take it back and if you have other problems then no doubt the users on the forum can help you out.

I echo the sentiments of the previous posts, open it up and use it.

It’s a great device, the UI and function are better than most of the players out there (other WDTVs included).

My WDTVLIVEHUB has the dreaded on-blinky-off disease as well.

Had a lot of stuff on my drive, pictures of my kids, ect. Didn’t really want that to go off to some factory somewhere. And what’s to say the unit I get to replace it is not equally broken.

After some thought I decided to open my unit up and unplug the On button from the main board. The case was far easier to open that I thought, I just used a thin plastic card ( similar thickness to a CC) around the seam at the top of the unit and it all came away without any fuss. Not a mark anywhere.

Unplugged the On button and plug the power back in, The unit started up immediately and bootedinto the Mochi GUI for the first time in 2 days. All I can say is thanks WD for making a problem kinda easy to fix. On the other hand I would have stern words with your QC dept because they SOOOOO dropped the ball on this one. Whatever shortcuts you took to save money will cost you in lost sales. Lose 1 point for a school boy error.

If the unit keeps going until the warranty runs out, I may reef the button out and try and figure what went wrong. We shall see.


Just thought I’d let everybody know that I’ve had the same problem on the current firmware, so took a blunt knife to the case, opened it and with a pair of the wife’s tweezers unplugged the lead to the ON/OFF switch.

The unit started up immediately and is still behaving itself  :smileyvery-happy:

I’ll keep it under observation though … if it plays up again it’s going back.


DeadHub wrote:

 All I can say is thanks WD for making a problem kinda easy to fix.

Love it!  That’s a great way of putting it.

With lots and lots of people succesfully prying open their HUB, Now i have the confident to upgrade the Firmware :slight_smile: and not worrying. Also i want to thank WD staff for joining the Forum, because its boost the confident that our soon to be pryed HUB will still be in warranty :smileyvery-happy:

I also tried disconnecting the power button from the front, and can confirm mine is working correctly.

I purchased my WD TV Live Hub as a returned item. Upon turning it on it was booting to a WD TV logo screen  with loading Mochie…then shut off and rebooting. My guess it is trying to sync video output to TV. What I did to fix it was:

  1. Wait for the loading Mochie…to appear.

  2. As soon as you see it just start hitting Home button on remote bunch of times. Home screen will load.

  3. Go to settings_system and do a factory reset.

  4. Mine rebooted and home screen appeared as normal.

I think the unit remembers last sync setting and it something changes, it just goes into a endless loop looking for last sync setting. Just a guess.

Same issue with my Australian delivered version. Was ok for 3 days. Pulling the cable from the power PCB did the trick. Would love it if WD figured out what the issue is and sent me the replacement bit. Took me 15+ hours to sync my Lace… not keen on doing that again. Latest firmware. P/N: WDBACA0010BBK-00 DCM: BBAEAA Thanks for the tip. JJ


I really would like to have a sense if this power button issue is widespread, that is a latent defect in all units, or just an isolated failure mode common to only a batch  or run of units. 


I have the same issue and reading through the posts it seems to be mainly DCM:BBAEAAA (same as mine). And please correct me if I’m wrong but it seems a lot of Australian users have the issue so I’m thinking this is a batch mainly sold in Australia.

I solved this issue by disconnecting the power button as described in this thread. By the way thank you so much  b0y0ng99 for your post ! Great work. :smileyvery-happy:

This all highlights the biggest problem with the unit;

When it fails, as it will fail someday, your data is stored on an internal HDD which you cannot access without stripping the unit.  This could cause some serious problems.  I am going back to my old WD TV Live unit I think, very reliable even if it lacks the new UI.

btw, I noticed some talk about other brands … As a person who has tested them all, I will tell you that WD units are the most reliable, robust, and adaptive units on the market.  While some of us have had problems with the new Hub (me included) don’t make the switch to one of the other brands, its not worth the pain it brings.

Your Welcome adutchoz!

My hub was bought in U.S. and the DCM is BAAEAAA (different than most of the units that’s having this problem which is mostly BBAEAA) but my hub also has this problem so I think lots of U.S. users also has this problem.

Before fixing the problem, I also tried what rweidman said in his post wherein pressing the home button in the remote while booting but that didn’s work for me.

I’ve got some questions for those of you with this issue: If you press the power button on the front of your unit, do you feel it click? Does it feel like it’s stuck? Does it feel squishy?

If you’ve opened your Live Hub to disconnect the power button and you happen to have a nice camera, can you send me some close up photos of your power button daughterboard and the plastic power button itself?

As we’re looking into this, we want to make sure our findings agree with the problems you’re experiencing.

I don’t think it has anything to do with the button on the case. When the cable was plugged in, I removed the PCB from its position (just hanging outside the case) and it still didnt boot. The clicker button on the PCB seemed to work fine when pressed. Again unplugging the cable did the trick… although I did notice that when I turned the unit of from the remote the fan still seemed to be spinning (but hard drive was off). Disconnecting and reconnecting the power fixes this.

I sent mine back before I saw the post re the power button pcb fix. I remember that I pressed the button a few times, and it had the proper click that you expect from that sort of thing. Probably why I didn’t invetigate any further down that path. I managed to get  the hub apart so at least I got all my movies off the hdd before returning it. If I only waited an extra day, I could have fixed it myself instead of RMA’ing it for who knows how long.

I think that its great that the workaround to the issue is to open up the unit and disconnect the power button cable, however many speak to this at THE fix to the problem.  In reality, it is not a fix but only a band aid workaround;  doing this results in the loss of functionality of the power switch.  If the equivalent capability is provided by the power button on the remote, I guess that is acceptable to some, but I don’t see this as the final WD fix which should be a correctly functioning power button capability on the unit.


I’ve just checked my power button (I removed the connecting lead a few days ago - see earlier post) and it ‘clicks’ fine … but I’m NOT going to reconnect it, now that the unit seems to be working well.

YES, I live in Australia as observed in another post and my DCM is : BBAEAA


I’m still waiting for my replacement unit, but for the power button; I expect it to be a simple momentary contact mechanism, without any click.

This allows it to pull a pin high or low for the duration of its press, since short & long presses do different things.

Mine was a Singapore bought unit, expected to be the same batch as the Oz ones.