HELP! Downgraded from Win8 and now hard drive has lost it's volume drive letter!

I recently upgraded to Win8, hated it, and went back to Win7. I didn’t remove my WD5000aac external hard drive in the process, and when I went back to Win7, it has lost it’s volume drive and I cannot access the files on it (Was fine when I upgraded to Win8).

I uninstalled the external hard drive, and plugged it in again. Win7 recognised it, added the correct driver and says its ready for use. I can also see it it ‘device manager’, and it says it’s all working fine. Just no volume drive letter allocated.

I can also see it in disk management, but again, it has no volume drive letter and the ‘assign drive letter and paths’ option is greyed out and not available. In fact nothing is available except ‘delete volume’ and ‘help’.

Things I’ve tried already, but haven’t worked;

[1] Stripped the casing from the hard drive and installed it like a regular internal hard drive.

[2][Tried to find a new driver, but a new driver is not available or required for this external hard drive >…Gw%3D#ELEMENTS When I plug the HD in, Windows7 recognises it immediately, installs the correct driver, and a message pops up informing me ‘Your WD5000 external hard drive is installed correctly and ready to use’.

[3] Went into Device Manager and disk management section, where it shows as being there, but doesn’t have a volume drive letter. I know I can ‘delete’ the drive, format it and then allocate a volume drive letter, but obviously I need access to the contents on the hard drive first.

[4] Opened CMD and used Diskpart to allocate a drive letter to the drive.

[5] Downloaded and used the WD Data Lifeguard Diagnostic for Windows to scan the disk for errors (none).

Does anyone have any ideas how I can access the files as they are really important?

Any help much appreciated.

Well not sure how removing from the enclosure would help on this case

any how,  you can try a recovery software

I’ve used Recuva , TestDisk and Minitool but there are many other options

Sometimes booting from a Linux Live CD will allow access also.


Tried Recuva yesterday, but no joy as the external hard drive has no allocated volume drive letter, so it doesn’t appear in the drive options.

I installed Ubuntu on an old laptop with the external hard drive attached. Got excitied for a second, as the drive was visible with some files showing, but they were something ubuntu put on. I could not access my original files. It stated there were 40GB of files that were not accessible. I will check this out again though, as I’m not familiar with Ubuntu so may have missed something.

Looks like this has stumped everyone.