HELP! Can't Access ONE Particualr Folder - Vista wants to Fromat


#1

Ok so I’ve scoured the posts on this forum so I apologize if this has been answered before, if so could someone please point me in the right direction! Here’s my situation:

I have a 1TB WD My Book Essential.

I’m running Vista 32-bit home edition

My external hard drive has been working fine for the past couple of months, I don’t use it as a back up I just use it to store my movies, pictures, and music. Last night I went to access my movies folder and Vista just kind of hung for a second and then prompted me to format the drive (which I declined). Now I can access all the other folders on my external hard drive just fine, but all of a sudden Vista won’t let me into my movies folder. And when I right click on the folder and go to properties it says its empty, but when I look at the free space on my hard drive its showing as if my data is still there. I’m not sure if this is some funky permissions thing all of a sudden or what, but if anybody has had this problem before please any advice would be greatly appreciated.


#2

Ok, I guess people are looking and this post and either have no clue or are beyond any forms of condolensces for me LOL. Anyways here’s an update:

I decided first things first that I’d update my firmware (BIG MISTAKE). First I couldn’t even get the darn thing started I kept getting “Device in Use” no matter how many programs i closed. I even ran it in safe mode for over an hour still no luck. Finally I powered down the MyBook and restarted and the Firmware kicked off only it didn’t show my SN just said “MyBook or MyPassport?” After realizing this I killed the firmware update (SECOND BIG MISTAKE). My drive was no longer recognized for about 4 hours as everytime I powered down and plugged it back in my SATA to USB controller driver could not be found (Initio Default Controller) So I scoured the internet searching for a compatible driver for the INIC-1610 (the USB/SATA controller for the WD HD) - NO LUCK. Finally I switched around the cables restarted my machine a bunch of times and let the MyBook alone unplugged for a couple minutes, plugged it back in an VIOLA it found the driver again. After one final restart the WD Smartware FINALLY recognized the drive and this time I just ran the firmware again without it detecting my Serial Number. When I navigated to the MyBook drive to my surprise my Movies folder which I could not access in the beginning is now TOTALLY GONE!! WTF? The space is still allocated for it if I right click on properties and even WD Smartware shows that I have 100+ gigs categorzied as movies on my harddrive. So why can I no longer even SEE the folder (not that vista would allow me to access it anyway).

ANY IDEAS?

ANYBODY?


#3

This recently happened to me with my 2TB Mybook elite and a large folder containing many gigs. Much like you movies folder. 

It was due to bad sectors on the drive. The reasoning behind this most likely is that that particular folder traversed more of the drive than any other folder, and happened to traverse the bad folders.

Suffice it to say. my Mybook is on RMA to WD right now x 2 weeks. Be careful if you use advanced RMA where they send you a drive first, because they will charge your Credit card right away, and not after the 30 day grace period has begun.

After searching for a while on the internet, I found the best program to find out if my drive had bad sectors, and fix them (ie: reallocate them to no mans land - an area which all hard drives have for spare. Long story behind this that says all hdd’s have bad sectors almost out of the factory, and are reallocated before sale).

Anyways, use HDDRegenerator.exe (google) to scan the drive first. You can also use it to repair the bad sectors. When the program loads you can click the top one third of the window to scan within Windows, and not on boot from an ISO. 

Yes it can fix the sectors as it did with mine, but bad sectors are a sign usually of eventual drive failure. Mine worked after the sectors were repaired by HDD Regenerator, but I still RMA’d because thats best in the long run.

All the best.