HELP! Cannot Disconnect My Passport from USB Port

I am a new user of the My Passport.  Every time I try to disconnect My Passport from the USB port, I get an error message stating “The device My Passport Essential USB HDD could not be removed.  Please close all running programs and try again later.”  I have tried over and over again, atter closing all programs, disabling anti-spyware and anti-virus protection and firewalls.  Nothing seems to help and the WD people themselves have not been able to give me a solution either.

try logging off then back on. I have some sync software that causes that and it works for me.


Thanks for trying to help me, Joe.  But I’ve tried  logging off and then back on again many times, along with my closing out all active programs, anti-virus, etc.  Any other suggestions?

By the way, I get the exact same error message when I have tried to download and install firmware updates that WD has issued.

Have you ever received the error message about needing to close out all programs, etc.?

Have you ever had any difficulties in disconnecting My Passport?

Thanks again,



Try the following steps:,195,312/session/L3RpbWUvMTMxNDA3NTk0Ny9zaWQvY1BQYlNkQ2s%3D

Answer ID 274.

Hope this helps.

I had same issue with My Passport Essential when using it in Windows 7, here is a simple solution:

On your taskbar, click the Windows logo (Start), type in “cmd” without quotes then you will see cmd.exe application in programs, right click on cmd.exe and select “Run as administrator”. Click “Yes” when a window appears. Now type the following command and press Enter:

chkdsk /x d:

 where d: is the drive letter of your My Passport drive that is connected, it could be different on your computer.

Now, what it does is that it forces your drive to unmount (ONLY IF THE DRIVE IS IN USE), and then checks your drive, (it’s a Windows check disk utility so it will quick scan your drive after unmounting it), means you can safely disconnect it now without even using the “Safely remove…” option after the scan completes. To confirm that it has unmounted try to open the drive from Windows Explorer, it won’t open.

This is the only way I’ve found disconnecting it if it does not disconnect the normal way (i.e. using the “Safely remove…” option).

Also after doing this you can also use WD Firmware Updater to update drive firmware if it wasn’t possible before or just unplug your drive from port with or without need to use “Safely remove…” option (at least try doing it to be on safe side, so that drive may turn off properly).

This problem was solved for me after installing WD SmartWave and setting the drive lock. But if you try to do the same and problem still persists for any reason, just use the method I told above.

I hope this is helpful :smiley:

1 Like

Thank you switching off the indexing worked for me. Steve

Awesome! Glad that it fixed the issue.

Have a great one!