Help -- Cannot connect to drive


I connected mybooklive 2TB to my router, ran setup on my Win XP home machine (wired connection to router) ran discovery and all was working fine.  I then made three changes:

  1. Registered with WD

  2. Changed workgroup from “WORKGROUP” TO “HOME”

  3. Updated the firmware

At this point the problem began.  When the firmware update was complete I got an error message and was no longer able to connect to the drive.  I checked the drive and LED was green.  I did the following:

  1. Shut down computer, drive and router.  Restarted router, then drive, then computer.  Re-ran discovery – failed to find drive.

  2. Tried to find drive in browser via “http://mybooklive” – got redirected to

  3. Tried to ping mybooklive.  Ping failed

  4. Found IP on router configuration page.  Tried to ping IP, but that failed.

  5. Tried to reboot drive – nothing happened.

  6. Tried connecting drive directly to my computer.  This did not work.

  7. Called WD support – they were unable to help.

Level 2 support is not available on weekends.  Any help would be appreciated.



Were you able to fix this issue?