HELP! Bought a MY Book Thunderbolt - and nothing works!

Invested in a new My Book Thunderbolt with Raid - wanted to use it for time machine and external drive.

Plugged it in - all seemed fine.

However, couldn’t partition it.

Now the drive isn’t visible at all!

Having surfed this forum (and others) there seems to be very many problems like this and no solutions.

Should I pack it up and send it back ?

Running a mid-2011 mac mini with El Capitan…

Any suggestions

The first thing you need to do is determine where the problem is. There are 4 possible choices:

  1. The actual My Book Thunderbolt
  2. The cable between the My Book Thunderbolt and your Mac
  3. The Mac
  4. The power adapter from the My Book Thunderbolt to the wall

Based on the symptoms, it could be any of them although it’s less likely to be the power adapter than the others.

To determine where the problem lies, the first thing to do is to try a different data cable to see if the drive is recognized. If it is not, than try the drive (with both cables ((one at a time)) on a different computer. Is it recognized there?

If it is not recognized on multiple computers with multiple data cables the problem is either the power adapter or the device - as you just purchased it, I would take it back to the store and exchange it for another one. Drives get damaged pre-purchase all the time - for all you know it fell off the shelf in the store.

Thanks for the reply

Perhaps i should have been more specific when i said it couldn’t be seen. The WD Drive utility sees it fine and reports all is well.

In finder no disk is visible.

The Mac disk utility sees two physical drives but they are not accessible, but the mountable drive that was ther first is no longer visible.

can’t help thinking this is a user error, software or firmware issue…

What version of Mac OSX?

El capitan 10.11.1…

Is it possible that the drives are formatted NTFS? According to https://discussions.apple.com/thread/7251817 Apple is telling customers that NTFS formatted drives are not supported.

No they’re not NTFS…

Try unmounting and remounting the drive in Terminal. Here’s some quick instructions on how to do this:

Thanks again - can happily mount/dismount the disks this way - each time message comes back to say the action is successful - nothing appears in disk utility though.

Seem to be communicating with the drive but it’s still not usable…

hmmmm…

One more thing to check…

in terminal type:

chflags nohidden /Volumes/<Volume Name>

(replacing <Volume Name> with the actual name of the volume)

I can’t see why a hidden flag would have been set, but just want to rule it out as a possibility…there’s a way to do this in the UI, but I don’t know El Capitan very well and am not sure where its been moved to.

Hi
(My Book Thunderbolt 6TB drive)
I have the exact same problem as this and have followed all the steps with no improvement. I have bought a new cable which has no effect. I have tried a second mac. Drive shows in Disk utility and terminal but won’t mount. Full drive check using WD Drive utilities completes with no problems. Any ideas as I have a lot of data on the drive.

@Andrew_Donovan - What happens when you connect it to a Windows PC? Does DataLifeguard for Windows see the drive?